HughesNet Community

Can't connect Xbox 360 to HT2000W

Showing results for 
Search instead for 
Did you mean: 

Can't connect Xbox 360 to HT2000W

hey folks,
So I recently moved to an area where satellite Internet is the only option. I went with hughesnet. I'm not super tech savvy at all, so this is baffling to me, but I have a HT2000W router (or modem, not sure what the difference is), and am having MTU error messages every time I try to get on xbox live. My 360 is able to connect to the network, and very rarely from the network to the Internet, but never from the Internet to xbox live. Does anyone out there who's had hughesnet or experience with them know what the problem is? And/or how to get around it? I've tried the wireless and hard-line option, but both are giving me the same error messages, and ultimately keeping me from being able to get on live. Any help would be appreciated. Need the help of a tech wizard who can explain solutions to me like they're explaining something to a 4 year old. Thanks.
Associate Professor

Is your Xbox 360 being directly connected to the HT2000w?  
You don't have a third party router between it, and the HT2000w, do you?

What results do you get when you go to Settings > System > Network Settings > (Pick which network type your using) > Test Xbox Live Connection?

You should have three test objects, Network, Internet, and Xbox Live.  They should all show connected, below that will be the Xbox Live Status for Xbox Live Services, which can be disregarded.

Next, what results do you get when you go to Network Statistics?

Mine are - 
Network: Connected
Internet: Connected
Latency: 611ms
Packet Loss: 62%...
Upload Speed: 8.28Mbps
Download Speed: 44.04Mbps

Have you tried disabling/enabling Web-Acceleration to see if that makes any difference?
Go to!/wac/control then click on the green box, "Web Acceleration Enabled", it should change to orange.  After a few minutes try to connect again.

I am having the same problem as the first post. I cannot connect to Xbox Live. I called xbox and went thru some steps and they determined that it was a port fowarding issue. I called and was on hold 1hr and they said that they could help me with the problem. They asked me for the ports and told me to hold on and then they hung up on me. I called xbox and told them what happened and they told me that they cannot help people with port fowarding they are not allowed too. So I am going to try what you said. I went ahead and tryed my asumptions of what to do and it still didnt work. You can go to and click advan settings, NAT and click port mapping/triggering and I filled in the info and it didnt work. Please help me if you can.



Can't really forward ports with the HT2000w on Hughesnet since we don't sit behind a public facing IP...

When you do the xbox tests that I stated above, what do you get...?

You are getting MTU errors, correct @hunterhancock41?

The more and more I look at this, it may be related to an already known issue, but I am unsure... Are you able to visit the xbox live website and log in there?

Distinguished Professor IV



To whom is your question directed?  

Ryzen 5 3400G | MSI B450M Pro-M2 MAX | 16GB Corsair Vengeance DDR4 3000 | XPG SX8200 Pro 512GB NVMe | Windows 10 Pro

@C0RR0SIVE, I've tried the wireless and direct connect method from the xbox to the router/modem. I have no third party routers. 

When I select "Test XBox Live Connection", the results are: Network: Connected, Internet: Failed, Xbox Live: Blocked.


As for Network Statistics, they show...

Network: Connected

Internet: Failed

Latency: Blocked

Packet Loss: Blocked

Upload Speed: Blocked

Download speed: Blocked

Signal Strength: 100%

Wi-Fi speed: 12 Mbps


I tried the Web-Acceleration enabling/disabling option this morning with no luck. Any other ideas?

I have no ideas...  I don't see why it's being blocked, this will probably require engineering to look into it... @Liz got any ideas or care to poke an engineer for some insight?

@Craigmcdonald22 and @hunterhancock41 can you guys try resetting the Network Interfaces on your xboxs?
Settings > System > Network Settings > Select the Network Type you are using (Wired or Wireless) > Configure Network > Additional Settings > Restore to Factory Defaults

Aside from that, I think this is going to require someone with more back-end knowledge to look into, it could be a gateway issue of some kind.

OK.... Now I am getting the same issue as you guys... Was working fine last night... Now it's failing tests.  Certainly not an MTU Settings issue though.


I've reset the xbox to it's factory defaults multiple times. really baffling. any other suggestions?

Sadly, I am out of ideas, having hopes that @Liz can look into this tomorrow at some point.

I couldn't connect most of the day today, and now I can... Seems like a backend issue, possibly related to the Access Denied errors that people had been getting, though I think that was fixed.

Good morning everyone,


Welcome and thanks for posting details and working with C0RR0SIVE. I'll run diagnostics to make sure your systems are working normally and send over the information you've gathered so far to our engineers.


Can you also please let me know the exact error message you're getting? Is it always the same message?


When exactly does the error message pop up? (E.g. Immediately after connecting the Xbox to the network, after sign in, etc?)


I'll post back with any other questions and other news from the engineers as I get them. Your cooperation, patience, and understanding are much appreciated.






If you have a tech or billing question and need help, please start a new thread in the appropriate board. Unsolicited Private Messages may not get replies.

Slow performance? Click me!

@Liz, After I select my network, I run the "Test Xbox Live Connection" test. It connects to my  network just fine, but I always get the "MTU Error" message as it tries to connect from the Network to the Internet. If I reset my router/modem, it WILL connect to the Internet, but not Xbox Live. It only does it once though. If you run the test again after not touching anything, it goes back to the MTU error. Hope this is the information you were looking for.  

@Liz I wasn't getting an error message when trying to connect when mine errored, it was just complaining that it couldn't connect, and that everything was blocked.  A certain engineer in a certain setting (You may have to ask @Amanda or peek into a special area on the net) was thinking it may be tied to access denied errors, but I personally didn't have any of those errors come up while browsing.

The only place I saw mentioning of MTU issues was during connectivity diagnostics on the console.  

@C0RR0SIVE@Liz were you folks ever able to find anything out about the connection issues?

@hunterhancock41, were you able to get yours to connect? 



Our engineers are still looking at this, no news of any potential fixes yet. Once I hear anything I'll let you know.


If you have a tech or billing question and need help, please start a new thread in the appropriate board. Unsolicited Private Messages may not get replies.

Slow performance? Click me!

Hello Craigmcdonald22,


Thank you for your patience while our engineers work to address your concerns. Please try the steps here and let me know if they help.


Looking forward to hearing back.


If you have a tech or billing question and need help, please start a new thread in the appropriate board. Unsolicited Private Messages may not get replies.

Slow performance? Click me!

Liz- any luck in solving this issue??

Hi tamzemp.


I've replied to your original thread here, please check it out.



If you have a tech or billing question and need help, please start a new thread in the appropriate board. Unsolicited Private Messages may not get replies.

Slow performance? Click me!

If I can add: If you're getting errors during the network setup, ignore them if it's at least getting past the internet stage. It has to do with the way the system is double-NATed. The internet part will still work.


Tried to download a game this morning during the Bonus period and saw I was getting around ~4.8Mbps through the 2GHz wifi (XBox 360 doesn't see the 5GHz one). It was a 7.6GB game so a 5 hours download wait was a non-starter. Saw this thread and decided to investigate:


1. When going through the 2GHz channel I'm getting really high upload speeds (over 3Mbps) but lower than expected download speeds (~4.8Mbps), negotiating an 12Mbps channel even though it has 100% signal.


2. Decided to try going through my legacy Cisco router that's still there for the older game adapter I'm using as the point for the downstairs DirecTV box. Despite high latency (over 1000ms) I'm getting the same upload, but much higher download speeds (21.2Mbps), negotiating an 54Mbps channel.


3. "Borrowed" the ethernet cable that I use for a co-located DirecTV box in my office and saw better upload speeds (5Mbps) and even higher download speeds (33.9Mbps).


I've tried toggling the UPnP (as @Liz suggested on another thread) on both routers, as well as toggling Web Acceleration. All done independently and together, and no combination made much of a difference.


21 and 34Mbps is somewhat acceptible given the speed rating is about that, but its a little disconcerting considering the 40-50Mbps speeds I'm getting through the 5GHz router port. Could just be the time of day or conditions at the other end.


That said, it almost seems as if there is some kind issue with the XBox 360 and the HT2000W's 2GHz wifi - at least in my setup. In theory, the only difference between them is:
Cisco    HT2000W

WEP        WAP2

 b/g*          b/g/n

* Cisco has n mode only on its 5GHz port, not it's 2GHz one.


Hope this helps somebody.

* Disclaimer: I am a HughesNet customer and not a HughesNet employee. All of my comments are my own and do not necessarily represent HughesNet in any way.


Set the HT2000Ws 2GHz wifi to 11g-only and retested. Saw higher upload speeds (over 5Mbps) bit better download speeds (~11Mbps), negotiating an 54Mbps channel w/100% signal. Think this is the best it's going to do going this way.


Note: I tried 11b-only as well, and that wouldn't even connect - could this the problem that the others are having?


So, either the combination of all of them or 11n was partly the low-speed culprit. Going to WEP is not an option, since it's not supoprted.


Still sticking with ethernet in the meantime for anything serious.

* Disclaimer: I am a HughesNet customer and not a HughesNet employee. All of my comments are my own and do not necessarily represent HughesNet in any way.

So, I am having trouble downloading/updating games on our Xbox one. Wondering if I use an Ethernet cable would allow the updates. I have not tried re-setting the Xbox wifi setting to factory specs, nor have I looked at any settings on the gen5 router. I can connect to the internet and make purchases through our Xbox. I have looked at the detailed network statistics on our Xbox and get

Download 0%

Upload 1.78mbps

Packet loss 100%.   Latency 0 ms.  MTU 1500   wireless strength 100% on the hug2 wifi. Same results on the hug5 wifi. @Liz