Hughesnet Community

Double NAT on Xbox One with GEN5

Showing results for 
Search instead for 
Did you mean: 

Double NAT on Xbox One with GEN5

Has anyone found a way to fix the double NAT issue on Xbox One. Would something like a LinkSys work to reroute for one address? Turn off the wifi on the modem? I'm so confused at this point. Any help would earn you a gold star!! Thanks.


I am having the exact same problem. I called customer support and they left me on hold for over an hour. Please help get rid of this double NAT problem that has popped up.

First I called HughesNet, they told me to call Xbox. I spent all day fartin' around with Xbox and the settings. Xbox couldn't help. So I called HN tech support. She told me the only way to fix it was to go back to the GEN4 modem instead of using GEN5. I told the HN guy what tech support said. He said no they wouldn't do it. I told him I wanted to talk to supervisor. He put me on hold for 20 min's and then came back and said "he spoke with the manager" and said no they wouldnt do it. He told me to call Xbox and ask for specific ports to be opened. So we did that. It still didn't work. We are limited in our internet choices out here. This is insane. There has to be a solution.

Associate Professor

How are you guys connecting your Xbox Consoles?  They should be connected directly to your HT2000w either via Wifi, or a network cable, with no third party router in between.

However, you will most likely still see Double Nat error (I think M$ calls this Strict NAT), as you are behing CGN (Carrier Grade NAT), and then local NAT  at the modem level.  There is no way around this, and there never will be, as port forwarding, and bridge modes are not available.

You may want to read over this article, and tell us what NAT type is being detected as referenced in that article, as you should be able to game with friends regardless as long as they fall in one of the green checks when compared to your NAT Type.

Distinguished Professor IV



You forgot to post the link to the article.  


And I was hoping you'd see this thread.  I knew you'd have knowledge about this topic.   


Edit.  Removed link.  It was to the wrong article.  



NAT Type is moderate and below that it says Double NAT detected. It doesn't allow me to use party chat or game online at all like this. When it was first set up this morning my XBOX One X did not say this and it worked perfectly fine.

Well thanks to the customer service people at Hughesnet I'll be cancelling hughesnet's service and getting all of my money back. These jokers put me on hold for an hr and then hung up on me 4 time back to back. So first thing in the morning hughesnet is losing a customer in less than 24 hrs all because there customer service representatives are just that rude and ignorant.

No I'm not using a third party router. I was only using the Hughes HT2000W. It worked good while the tech was here and had me test it out before he left. Then last night I started having problems with it after we a bit of bad weather. It got pretty windy and rained hard until 8 or 9 PM last night. Then after that is when I started having the problems with my internet. It didn't just effect my XBOX One X it was effecting everything I tried to do online. I couldn't even watch YouTube. That's how bad the internet got and ur customer service is straight garbage. If it customer service was better and I mean way better u would still have me as a customer. I cancelled it service and went back to using the internet company I have hated for yrs. That how bad ur customer service is. I would rather be over charged for slow internet with semi ok customer support than be over charged for internet I can't use at all with the worlds worse customer support. Ur customer service alone is going to cause u to lose a lot of ur customers. My parents got rid of u also for the exact same thing. U really need to do better and train it customer service reps better.

We tried all sorts of configurations and also plugging it directly in. Nothing worked so we are having a tech guy come out tomorrow. 

Associate Professor



Hrm, did you try resetting the xbox as described in the article I mentioned in my last post to get it to perform upnp?  When doing this, make sure you reboot your modem just prior to doing this on the Xbox.

Yea, we did....thank you for all your help.

Associate Professor

The only other thing I can even think of suggesting is disabling IPv6, and manually set an IPv4 address on your Xbox One that will work with your local network...

It's worth a shot. Thank you.

Has this problem been solved? I just started having this issue 4 days ago. I can play online but can't party chat with any friends. I've reset the modem and that doesn't fix it.

Hi Raganrsx,


  I see it's your first post here, so welcome to the community! Did you catch C0RR0SIVE's posts earlier in this thread? He has some good explanations and things to try. Good luck!


If you have a tech or billing question and need help, please start a new thread in the appropriate board. Unsolicited Private Messages may not get replies.

Slow performance? Click me!