cancel
Showing results for 
Search instead for 
Did you mean: 

Latency Speeds Making Streaming Unusable

Highlighted
New Poster

Latency Speeds Making Streaming Unusable

I have been having streaming problems since I signed up with Hughes but over the last 2 weeks it has become unusable. I did a latency test on testmynet and was getting between 300ms and 12,000ms. When I originally got Hughes I spent over 3 hours on the phone with various techs trying to get things working properly. We would get it streaming smoothly and then a few days later it would be back to choppy internet, you know the dreaded spinning circle. I had problems with ViaSat but nothing like this. Any suggestions for improved latency? I am using Roku as my streaming device and it usually shows between 1 to 3 mb even after my monthly reset. It is on a Lan connection.

1 REPLY 1
Highlighted
Distinguished Professor III

Re: Latency Speeds Making Streaming Unusable

You can't change the satellite's latency, as that's due to the laws of physics.  Another type of latency is network latency, and this is caused by many different factors, many of which have little to nothing to do with HughesNet and may be caused by network traffic, websites issues, Internet backbone issues, and others.   

 

The pandemic has caused ISPs, including satellite ISPs, to deploy network management practices that may be affecting your ability to do some tasks, and one of them is streaming.  Streaming issues, like other issues, are not consistent, so your system may work amazingly well one day, and not work at all the next day. 

 

Going by info on the Viasat community, their subscribers are also experiencing issues, same as we HN subscribers are. 

 

Latency tests on Testmy are not reliable.  Your satellite latency will be around 600ms, and you can test it by running traceroutes.  At times that latency can go up, depending on many factors, but running traceroutes gives you a more accurate picture than what the Testmy latency test can give you. 

 

2willowsfarm wrote:

I have been having streaming problems since I signed up with Hughes but over the last 2 weeks it has become unusable. I did a latency test on testmynet and was getting between 300ms and 12,000ms. When I originally got Hughes I spent over 3 hours on the phone with various techs trying to get things working properly. We would get it streaming smoothly and then a few days later it would be back to choppy internet, you know the dreaded spinning circle. I had problems with ViaSat but nothing like this. Any suggestions for improved latency? I am using Roku as my streaming device and it usually shows between 1 to 3 mb even after my monthly reset. It is on a Lan connection.