cancel
Showing results for 
Search instead for 
Did you mean: 

My Gen5 Internet speed is 98% slower than nation. 5 Tech Support Calls, still no resolve

Highlighted
New Member

My Gen5 Internet speed is 98% slower than nation. 5 Tech Support Calls, still no resolve

My Gen5 Internet download speed is so slow it is completely useless.  We can't do anything on the net.  I called Tech Support 5 times over the past week and a half.  Each time it takes 20-40 minutes to get to talk to a live person and each time they claim my case as been escallated to the Tech Team for resolution and that someone will call me back in 24 hours which never happens.  They ensure they will credit me for slow days if I call back again (wait another 20-40 minutes to talk to someone) to advise how many slow days I have had once the problem is resolved which at this point seems may never happen.  Last speed test results tonight are ridiculously slow.  Can anyone recommend how to get through to the Tech Team to get this issue resolved?  Credits for slow days does not really help since I cannot do anything on the net at this point.

 TimeSIZE   SPEED
Fri Jan 05 2018 @ 7:16:52 pm576 kB149 kbps 19 kB/s
Fri Jan 05 2018 @ 7:15:59 pm576 kB 123 kbsp 15 kB/s
Fri Jan 05 2018 @ 7:15:08 pm576 kB163 kbps 20 kB/s
Fri Jan 05 2018 @ 7:14:29 pm576 kB165 kbps 21 kB/s
Fri Jan 05 2018 @ 7:13:45 pm576 kB178 kbps 22 kB/s
1 REPLY 1
Spectator

Re: My Gen5 Internet speed is 98% slower than nation. 5 Tech Support Calls, still no resolve

I am in the same boat. My internet is so slow it is showing to have 2.3mbps dowload. This is crazy I am paying too much to not even be able to watch a movie withought it taking 20 mins to start and buffer every 30 seconds. Trying to call Tech Support is next to impossible seeing as it takes 30 mins to an hour to get someone on the phone and they always say they did something to change it but nothing has changed. Its almost impossible to even search the web its so slow. If I am going to pay for this thing I need to be able to use it. It has never been close to fast since I got the service in October. I am also wondering if there is a fix for this. Any help would be much obliged.