Showing results for 
Search instead for 
Did you mean: 

New Usage Meter v.6.7

New Poster

Re: New Usage Meter v.6.7

Thank you for your suggestion, however, I have already tried that and it did not fix the meter.

I can go to the System Control Center through my browser, is there something there I should

look at?  

It is odd, that this update does not work, yet the previous one worked just fine.

Any other suggestions?


Re: New Usage Meter v.6.7

Hello TRider,


Since the steps I provided did not work and Avast already allows the status meter through, it wouldn't hurt to follow the instructions that @MarkJFine posted on the first page (deleting the HughesNet Usage Meter folder). Just make sure the Status Meter is closed before deleting the folder, then try opening the meter again after the folder has been deleted. Let us know if that works!



Associate Professor

Re: New Usage Meter v.6.7

Just for clarity: You should delete "C:\Users\[your User name]\AppData\Roaming\HughesNet Usage Meter\" where you replace [your User name] with <drumroll> your user name on the computer.


If you delete "C:\Program Files\HughesNet Usage Meter\" instead, it will delete the application, and there's no reason to do that.

* Disclaimer: I am a HughesNet customer and not a HughesNet employee. All of my comments are my own and do not necessarily represent HughesNet in any way.
New Poster

Re: New Usage Meter v.6.7

I have been running version since I purchased this new computer.  No problems

After being pestered to download the latest version (, the program can no longer find the HUGHESNET MODEM.

I uninstalled the version running and downloaded and installed  Same problems.

I uninstalled version and re-installed  Works just fine.

Windows  OS Version:                10.0.16299 N/A Build 16299

Fortunate for me, I have the original downloads on a backup drive.

Distinguished Professor IV

Re: New Usage Meter v.6.7



Did you try altering the settings mentioned in Amanda's post on the previous page?  

Ryzen 5 3400G | MSI B450M Pro-M2 MAX | 16GB Corsair Vengeance DDR4 3000 | XPG SX8200 Pro 512GB NVMe | Windows 10 Pro

Re: New Usage Meter v.6.7




I still think that the two users are experiencing a firewall problem.

I saw the error message on the taskbar once myself after the upgrade from v6.1.1 to v6.7.0.0

Usage meter IS running to generate that message on the task bar next to the network icon

I suggest be absolutely sure that the NEW version is not being blocked by checking the firewall logs.

here's a snippet of mine.

HN UsageMeter-rule.PNG


Re: New Usage Meter v.6.7

Pestered to upgrade the HughesNet Usage Meter, I accepted the request.  Message displayed 'A HUGHESNET MODEM CANNOT BE FOUND."

1.  Chose settings.  Unchecked the Use Default Modem address and saved it.  No change of status.  Changed the modem address to the address of the modem which I can access from my browser (which is the same as the default.)  Saved it and no change.

2.  Looked for solutions on the internet.  One suggestion was to remove the directory under appdata/roaming/HughesNet Usage Meter/Cache.  No change of status.

3.  Uninstalled HughesNet Usage Meter and downloaded the latest version.  No change.

4.  Uninstalled HughesNet Usage Meter and re-installed version  This still works.

5.  Upgraded the HughesNet Usage Meter from the app.  Unable to find the mode.

6. Uninstalled HughesNet Usage Meter and downloaded the latest version.


Re: New Usage Meter v.6.7

What port needs to be opened for HughesNet Usage Meter?  The older version continues to work. 


Re: New Usage Meter v.6.7

Im assuming that this is still the same GreyFox who commented yesterday,

@GreyFox200 wrote:

What port needs to be opened for HughesNet Usage Meter?  The older version continues to work. 

I dont know, but the answer to your question would be in your firewall history (logs).

I am just a user (not tech support) 

Amanda and @GabeU are BOTH very good at solutions, but They could be in the pacific time zone, very early there now.

Grey Fox, please be patient.


Your solution might be as simple as "allowing" HughesNet Usage meter to access the modem.

confirm that your security rules are allowing version to pass information to your local network.

Of course you would have to install it again. Smiley Frustrated

I suspect that v 6.7 announces itself a little different than v 6.1.1 does.  

could be why the old version still works and the new one is blocked.


Re: New Usage Meter v.6.7

Same GreyFox.  HughesNet made me change my User ID because the one I started with is taken.

I removed the power from the modem, shut down this PC, waited ten minutes of more and restarted.  Usage Meter 6.7 still fails.  From the status-meter.log:  "modem: Call to failed."

uninstalled 6.7.  Re-installed 6.6.1.  Works just fine.  Nothing in the status-meter.log.

I will ignore the messages to upgrade. 

If it works, don't fix it.

Did it work?  Yes.

Did you fix it?  Yes.

Does it still work?  No.