Showing results for 
Search instead for 
Did you mean: 

Pages Time Out


Pages Time Out

Several weeks ago I started having bookmarked pages I have used for years starting to fail to load - timed out.  It started with Yahoo pages then Money pages. None would load.  This last week I have now had the problem with other HTTPS pages.  myusps, mymedicare, etc.  

I have two systems on my computer, Windows 10 preview and Windows 10 Released.  I have 4 browsers on each system, Firefox, Chrome, Edge and Internet Explorer.  All 64bit version.  All fail with the same (wording different by browser) message.  All fail on the final TLS handshake with the individual websites, and all are HTTPS.  I have no problems so far with HTTPS sites with my banks or credit card accounts.  


Re: Pages Time Out

I'm having the same exact problem in the same timeframe with similar hardware.  Even Outlook cannot load.  Works fine on a one-bar cell connection on IPhone so I know it's related to HughesNet.  Ideas please.  I am frustrated beyond belief, can usually solve all my own computer-related problems, but not this one.

Distinguished Professor IV

Re: Pages Time Out



Can you please post a few of the URLs you are having issues accessing?    

Ryzen 5 3400G | MSI B450M Pro-M2 MAX | 16GB Corsair Vengeance DDR4 3000 | XPG SX8200 Pro 512GB NVMe | Windows 10 Pro

Re: Pages Time Out

Hi freeafrog,


Thanks for posting and providing the troubleshooting steps you've tried so far. If you provide us with further details, we can better assist you.


As Gabe already posted, what are some of the URLs you're trying to visit?


What exact error message are you getting? (Screenshots would help)


Have there been any changes to your system prior to your concerns?


Does disabling Web Acceleration make a difference? (Enter in your browser then follow the steps here to find where to toggle Web Acceleration:


Does this happen on different computers/devices?


Does this happen on a non-HughesNet connection?


Does this happen even after clearing your browser cache? (How-to here:


Does power cycling your modem make a difference? (Unplug the HughesNet modem's power cord from the brick for 30 seconds before replugging.)


Does this happen even when directly connected to the HughesNet modem?


Does power cycling your router make a difference?


Does power cycling your computer make a difference?


Your cooperation, patience, and understanding are greatly appreciated so that we can address your concerns.


If you have a tech or billing question and need help, please start a new thread in the appropriate board. Unsolicited Private Messages may not get replies.


Re: Pages Time Out

Speaking for Kathy, in case it's the same problem Freeafrog has.  If you prefer to address in separate thread, I will be glad to start another.


most recent sites,,, 

Sites that cannot be accessed on Win 10 browsers cannot be  accessed on IPad using Safari/HughesNet either.

Error message is ERR_TIMED_OUT

Sites work fine on Iphone/cell phone signal.

Caches have been cleared. 

HughesNet 1100 Modem and Linksys Router have been unplugged and reset. 

Internet signal strength looks low on router light.

No LAN port on laptop so cannot use cable directly from modem to laptop.

No system changes. 


Re: Pages Time Out

I would note it also took me over 6 minutes to log into Hughes Net.... 


Re: Pages Time Out

looks like all the https: sites on .gov

such as will not load either, give same error msg.


Re: Pages Time Out

I'm having the same problem.  Page loading on various https sites is stalling on TSL handshake.  This is happening a LOT lately on both my laptop and desktop, wireless and wired, with all browsers (Firefox, Chrome, Edge, Vilvaldi, IE). Tried clearing caches, flushing DNS.  Sometimes they eventually load, other times I give up. Rebooting the modem has helped at times, but only briefly, sometimes for just one page load, then it goes back to the problem. 


But then at other times, the pages in question load fine, so it's random.


Today I'm taking my laptop to work to check out how the pages load on a different network - I imagine it will be fine because a lot of time when this is happening I just get frustrated and decide to wait until I'm at work to look at what I need to.


Edit - it's similar to what @GabeU was talking about here:




Re: Pages Time Out

I called my local satellite guru yesterday (he mostly installs Viasat now so does not service me anymore) who said he has had a number of his old Hughes customers complain of the same issue in the last week or two.


Additional data point: checked speed yesterday (but over wifi), was ~ 24 up, 2 down, web response 2.7 sec.  So I do not think it's a wifi problem.  Will get an Ethernet/USB connector today just to see if that helps.  


We are still on Gen 4 and have plenty of data left for month. 


Still no success here with Outlook/other websites here. Off to the library now to download docs and send invoices.

Distinguished Professor III

Re: Pages Time Out

You all may want to do the same thing @GabeU did and capture some screenshots to post here.  The more data and evidence you have, the faster the mods can help you.  You all should also answer the questions Liz posed to you, as this would speed up the resolution of your problem. 


@slym wrote:

I'm having the same problem.  Page loading on various https sites is stalling on TSL handshake.