HughesNet Community

Reocurring issue with Social club app for GTA 5

cancel
Showing results for 
Search instead for 
Did you mean: 
Bob5
Sophomore

Reocurring issue with Social club app for GTA 5

It worked for almost 2 weeks then here we go again. A game I installed requires a connection to Rockstar social club. When I launch it it keeps timing out. There was an issue with this in the past on Hughes end but they fixed it with some kind of certificate. Can you fix this again? Rockstar automated emailed me and suggested that they were being blocked by Hughesnet. Please fix me.
45 REPLIES 45
Josh Trujillo1
New Member

Just sum information one is fourn show multiple people have this problem the other is about connection. I personally noticed trouble with my upload with haughes net over year ago went from over 800kbps 400 and under battled and faught with your company to get it working at that 800kbs had teach support teaches at house at never seen 500kbps in over year. The game use to be playable at under 100kbps upload
Bob5
Sophomore

Upload is fine but my download is rather slow. Never noticed since browsing is good.

http://testmy.net/db/nZfS9MumA

http://testmy.net/db/3wtpmFl1f

Bob5
Sophomore

Turn off web acceleration and it gets a little better but still slow.

http://testmy.net/db/VukYUJvbj.5lGe1qK4y

GabeU
Distinguished Professor IV

Bob,

Make sure when you do speed tests at testmy.net you use the 12MB manual size for downloads and the 2MB manual size for uploads.  It would also be a good idea to create an account at testmy.net and do your tests under that account so it can keep a running tally of tests in case your speed needs to be addressed by the reps in the future. 

Also, make sure that you are connected directly to the modem when doing speed tests.  No router. 

If you have Windows 10, your system might be updating as some updates were just released sometime yesterday. 


Ryzen 5 3400G | MSI B450M Pro-M2 MAX | 16GB Corsair Vengeance DDR4 3000 | XPG SX8200 Pro 512GB NVMe | Windows 10 Pro
Liz
Moderator
Moderator

Hi Bob,

Thanks for clarifying. I don't have any games to test the game client in RSC, so I won't be able to try reproducing your experience. However, I'm curious if you can run your game via Steam instead:
http://store.steampowered.com/about/

The steam client is only 1.5 MB, and once you have that, you can add your current copy GTA 5 to it so you can launch it via Steam instead of RSC, which is currently a challenge.

Here's how to add your game to Steam:
  1. Launch Steam.
  2. Click the Games menu, choose Add a Non-Steam Game to My Library.
  3. Browse for games on your computer or put a check next to the game(s) you wish to add to the Library.
  4. Click Add Selected Programs.
Please let me know if this works.

Thanks,
Liz
If you have a tech or billing question and need help, please start a new thread in the appropriate board. Unsolicited Private Messages may not get replies.

Slow performance? Click me!

Bob5
Sophomore

I wish it was that easy.I have steam with lots of games and they all work fine. I would have to purchase a new key to be able to play it and then download the entire game again through steam .If you add a previously installed game to library it just gives you a new shortcut but still goes through original DRM.
Liz
Moderator
Moderator

Hi Bob, 

I don't mean for you to re-download or re-purchase the game to play in Steam, that doesn't happen when you add a non-Steam game to Steam.

https://support.steampowered.com/kb_article.php?ref=2219-YDJV-5557

I'm just curious if this would make a difference in accessing the game.

-Liz
If you have a tech or billing question and need help, please start a new thread in the appropriate board. Unsolicited Private Messages may not get replies.

Slow performance? Click me!

Bob5
Sophomore

I tried but it didn't work. Same error.
CommunityWorklo
New Poster

Good morning Bob,

Thanks for trying and letting me know what happened. I can escalate your case to an engineer to see if there's anything we can do to help.

To recap (this is what I'll send to the engineers):

-Rockstar game client times out after launch
-issue started around July 5
-works on non-HughesNet connection
-issue persists while connected directly to modem
-issue persists whether Web Acceleration is enabled or not
-issue persists after browser cache
-issue persists when launched via Steam

The last thing I want to report with certainty is whether powercycling the modem makes a difference. Just unplug the modem's power cord from the power brick and replug after 30 seconds. Let me know if that helps.

Thanks,
Liz
Bob5
Sophomore

power cycling makes no difference. I have tried this daily. Thanks
Bob5
Sophomore

I don't know if this helps or not but this is my Social club log.

[00000000] Thu Jul 14 13:11:36 2016
[00000000] Rockstar Games Social Club SDK: RELEASE
[00000000]
[00000000] Command Line Arguments:
[00000000]   -scuiurlpath=/scui/v2/desktop
[00000000]
[00000000] Settings:
[00000000]  Offline Only Mode: false
[00000000]  Launcher Mode: true
[00000000]  Running title: gta5
[00000000]  Platform: PC
[00000000]  Language: English
[00000000]  Environment: Production
[00000000]
[00000000] Network initialized
[00000000] RAGE initialized
[00000000]
[00000000] Social Club Directory: C:\Program Files\Rockstar Games\Social Club\
[00000000] Root Data Directory: C:\Users\Bob\Documents\Rockstar Games\
[00000000] File System Initialized
[00000016] Version Info: 1.1.9.6
[00000016]
[00000016] JSON Interface initialized
[00000016] Metadata initialized
[00000016] Achievement Manager initialized
[00000016] Player Manager initialized
[00000016] Gamer Pic Manager initialized
[00000016] Profile Manager initialized
[00000016] Presence Manager initialized
[00000016] Commerce Manager initialized
[00000016] Task Manager initialized
[00000016] Telemetry Manager initialized
[00000016] Network interface initialized
[00000016] Steam Manager initialized
[00000016] Cloud Saves interface initialized
[00000016] Subprocess path: C:\Program Files\Rockstar Games\Social Club\subprocess.exe
[00000016] Rgsc initialized
[00000016]
[00000094] Social Club UI - Entering State: 'LOADING'
[00000094] Social Club UI - Entering State: 'WAITING_FOR_PAGE_LOAD_COMPLETION'
[00000094] UpdateConnectionState :: Connection state changed from offline to online
[00023543] [ERROR] Page load error, code -101
[00023543] Social Club UI - Entering State: 'LOADING'
[00023543] Social Club UI - Entering State: 'WAITING_FOR_PAGE_LOAD_COMPLETION'
[00046739] [ERROR] Page load error, code -101
[00046739] [ERROR] Failed to load social club UI, falling back to offline site
[00046739] Social Club UI - Entering State: 'LOADING'
[00046739] Social Club UI - Entering State: 'WAITING_FOR_PAGE_LOAD_COMPLETION'
[00046897] Social Club UI - Entering State: 'WAITING_FOR_JAVASCRIPT_BINDINGS'
[00046897] Social Club UI - Entering State: 'WAITING_FOR_JAVASCRIPT_PONG'
[00047000] Social Club UI - Entering State: 'WAITING_FOR_JAVASCRIPT_READY'
[00047105] Social Club UI - Entering State: 'JAVASCRIPT_READY'
[00047105] Social Club UI - Entering State: 'START_SIGN_IN'
[00047105] Social Club UI - Entering State: 'FINISHED'
[00047105] Finished loading Social Club UI
[00047105]
[00050939] Shutting down...

Liz
Moderator
Moderator

Hi Bob, 

Thanks for the log information, that actually proved to be very useful. I googled the error and found this insightful thread, which I've also sent to engineering: http://steamcommunity.com/app/271590/discussions/0/351660338726506515/

I'll let you know what engineering says once I hear back.

Your cooperation and patience are much appreciated.

Thanks,
Liz
If you have a tech or billing question and need help, please start a new thread in the appropriate board. Unsolicited Private Messages may not get replies.

Slow performance? Click me!

Bob5
Sophomore

Thanks for all the hard work, I really do appreciate it.
Bob5
Sophomore

Sadly it still is not connecting. Havent heard anything from Hughes or Rockstar for a good while.
Liz
Moderator
Moderator

Good morning Bob,

I haven't heard back from engineering either, I'll let them know you still cannot connect.

-Liz
If you have a tech or billing question and need help, please start a new thread in the appropriate board. Unsolicited Private Messages may not get replies.

Slow performance? Click me!

Bob5
Sophomore

Looks like my problem is getting worse. I cant even log in to their website. This page can’t be displayed.

Turn on TLS 1.0, TLS 1.1, and TLS 1.2 in Advanced settings and try connecting to https://socialclub.rockstargames.com again. If this error persists, it is possible that this site uses an unsupported protocol. Please contact the site administrator.  Before you ask Yes I have completely reset internet explorer and cleared cookies. This is the only site that this happens on. I am getting so sick of this.

GabeU
Distinguished Professor IV

Won't load for me, either.  Must be a touchy connection that doesn't like the latency or something else with Hughesnet.  It wouldn't surprise me if, in the end, Rockstar Games has to fix something.  I can get on their main site, though. 

Ryzen 5 3400G | MSI B450M Pro-M2 MAX | 16GB Corsair Vengeance DDR4 3000 | XPG SX8200 Pro 512GB NVMe | Windows 10 Pro
Liz
Moderator
Moderator

Good morning Bob,

Did this help? -> "Turn on TLS 1.0, TLS 1.1, and TLS 1.2 in Advanced settings"

Does toggling Web Acceleration make a difference?

Gabe, do you mean the game client times out too when you try to launch a game?

-Liz
If you have a tech or billing question and need help, please start a new thread in the appropriate board. Unsolicited Private Messages may not get replies.

Slow performance? Click me!

Bob5
Sophomore

Unfortunately no.
GabeU
Distinguished Professor IV

Liz,

No.  I don't have any games.  I just meant the site.  I can go to Rockstar Games main site just fine.

 http://www.rockstargames.com/

When I click on "Social Club" it times out, with the page never loading.  Even when using the direct link, at http://socialclub.rockstargames.com/ , I get the same, timing out with no page loading. 


Ryzen 5 3400G | MSI B450M Pro-M2 MAX | 16GB Corsair Vengeance DDR4 3000 | XPG SX8200 Pro 512GB NVMe | Windows 10 Pro
Liz
Moderator
Moderator

Thanks for the feedback, I've sent it up to the engineers as well. I haven't gotten word back from them about this case. 

In the meantime, have you read that Steam community thread in full? What I found interesting were these last two posts:

GRIZZLY  has Grand Theft Auto V Jul 4 @ 6:00pm 
*EDIT* I think I found the culprit, because my ISP is capped to 1Mbps and P2P blocked, and by research I found that perhaps Social Club and GTA Online uses some sort of P2P connection, thus preventing me from going online. Hence, using a VPN with bypasses the block enables it. Oh well, that is our crappy Malaysian ISP for ya. Guess I have to stick with some local VPN for now to minimize the lag....
Yup, I have set rules for those apps to be allowed through inbound/outbound in firewall. Nothing works except through VPN.
 
wolverine.23  has Grand Theft Auto V Jul 5 @ 2:18am 
I FINALLY FOUND THE FIX THAT WORKED FOR ME ,
ITS A SERVER PROBLEM ROCKSTAR SOCIAL CLUB CAN'T CONNECT CAUSE OF THE SERVER , SO YOU HAVE TO DOWNLOAD A VPN LIKE SOFTETHER VPN AND JUST YOUTUBE HOW TO USE IT , YOU MAY NOT BE ABLE TO USE MOST OF THE SERVERS BUT KEEP TRYING ANY OF THE JAPANESE SERVERS TILL YOU GET CONNECTED WON'T TAKE MUCH TIME I PROMISE TOOK ME 20 MIN IN TOTAL AFTER DOWNLOADING THE SOFTWARE AND ONCE YOU ARE DONE YOU JUST HAVE TO CONNECT TO IT ONCE AND OPEN THE GAME AFTER YOU PLAY THE GAME FOR ABOUT 5 MIN U CAN UNINSTALL THE SOFTWARE SOFTETHER VPN AND PLAY THAT GAME BACK ON THE INTERNET THAT YOU USE OR OFFLINE 😄 HOPE THIS WORKS FOR YOU CAUSE I HAD YOUR SIMILAR ISSUE 🙂
after issuing a ticket to rockstar about the server issues and vpn , after a couple of hours when i tried the online without the vpn i was able to sign and they sent some form to agree to and was able to play with no server issues again .. so i'd advise you to send a ticket to rockstar about this issue with your social club id and steam id .
I've also sent that thread to the engineers for reference. I know we don't block P2P traffic, but our legal site does state this: “In order to ensure fair access to all types of
traffic, however, we limit
the network capacity available for P2P applications, which has the
effect of reducing the priority of such traffic.”

As the Steam thread reveals, using a VPN may be the solution, however, using a VPN will certainly reduce your speeds by 50%-70%.

-Liz
If you have a tech or billing question and need help, please start a new thread in the appropriate board. Unsolicited Private Messages may not get replies.

Slow performance? Click me!