HughesNet Community

Speed issues and DNS issues for MS machines

Showing results for 
Search instead for 
Did you mean: 

Speed issues and DNS issues for MS machines

Got new router installed (though for its promise of long distance, it covers less than my ASUS router did. 😞 ).

Yesterday morning it worked perfectly fine (we are out of bandwidth for the month, so have to use bonus time). Keith woke up at 2am, I told him we attacked Syria, and he went online. His most commonly used page loaded fine, but more than half of the links on it gave DNS server not found messages. I got out my tablet (my laptop usually isn't in the bedroom), and everything worked FINE. My tablet is a Kindle Fire, and uses their specific web browser. Now I am really kinda curious. I go get MY laptop, and it does the same thing as Keith's. I empty the cache on hubby's laptop, reset its wireless settings, delete and reinstall the saved wireless networks, double-check my DHCP settings (the router defaults to the same ip address as my satellite modem)...

Another curious thought occurs to me, and I try to pull up the ip address to the satellite modem from a laptop. Same cannot resolve message. It is visible, though, to the tablet. Pinging works to Google and Yahoo, but when you use either search engine, many of the links they give you give you the same error. You can see the modem with my Kindle.

I powered down and restarted everything on my network, starting with the modem, then router, etc. I am seriously considering static ip addressing (but not entirely sure it would fix my problem)!

Also, did some preliminary speed testing last night (will have to do more when things slow down after prom) and had 6.2Mbps download, 169Kbps download. Can't remember the size we are supposed to use. Would like to have that for when I do further testing. However, if none of my laptops can resolve ip addresses, I might not be able to test outside of using my router, which, of course, will mean none of my results will be considered valid, anyhow.

Oops! Second speed there is upload.
Associate Professor


Have you checked to make sure the computers are setup to retrieve IP and DNS information automatically?  Also, are these computers connecting through the ASUS router, or connecting straight to the HT2000w?

How to set Network Adapter to Automatic

Yes. Everything in the network is set for dynamic addressing. ASUS router has been replaced by a DP-Link. New router worked seamlessly the first day, this cropped up about 60 hours after install. Used DHCP settings to give the router through to assign because default ip address for the router is

I have an HT1100. Been a customer nearly 2 years. Everything connects through the router to get to the modem, in part because the modem is in another building. We need to have it moved, but are debating which company to use going forward. I didn't realize that there were better plans available. When I go to upgrade plans on the app here (I don't use Hughesnet because of how expensive and limited the data plan is; I do all internet off my cell phone) all it offers are the same plans available when I signed up. I think the next jump up in data is something like 25GB for $129. Those numbers made Exede's offerings look really impressive. 😕

My modem only has one ethernet port, and the router is there to allow wireless connections mostly. It doesn't have wireless connectivity.
Associate Professor

Oh, you are on an HT1100... sorry, thought you was on the HT2000w since there have been so many with that modem lately.

I suggest trying a third party DNS on your router or devices to see if that helps with the DNS errors, such as Google DNS, or Norton DNS.  You may have to consult the manual for your exact model router to see how to change the DNS settings there.

How To Change DNS Settings to Google DNS

As for speedtests, the following should help, but we should aim to get the DNS issue resolved even if only temporary first:

Please keep in mind that Hughesnet will only accept and the official Hughesnet speed test results. Tests from other sites like are not accepted due to the compression technologies and latency that satellite deploys.

Most important points to remember during this test:
-do the tests while directly connected to the HughesNet modem with a LAN cable (NO third party Router or Wireless devices can be used)
-use the 12MB size download test file ONLY if on Gen4 Service Plan
-use the 25MB size download test file ONLY if on Gen5 Service Plan


-If testing upload instead of download, you must use a 4MB size upload test file
-space each test at least 5 minutes apart
-post your results URL here, it may look something like

For a more in depth guide on running the tests, please visit:

Thank you. I haven't tested in well over a year. I remembered the website, but couldn't remember the file size! 🙂

Weather has dried out and warmed up a little, maybe I will be able to get a test in Monday morning. Tomorrow is my son's senior prom, and Sunday is church.