Hughesnet Community

Super slow upload speeds

cancel
Showing results for 
Search instead for 
Did you mean: 
kelley.nesbitt5
Freshman

Super slow upload speeds

My upload speeds have become extremely slow in the past few days.  I just ran a test from myhughesnet and upload was .39. Is this normal for Gen 4, Pro package? 

31 REPLIES 31
GabeU
Distinguished Professor IV

@kelley.nesbitt5

 

How have your download speeds been?  

 

What kind of upload speed are you getting when testing at testmy.net with a manual 4MB upload size?  

 

If not still using http://testmy.net/quickstats/knesbitt , it would be a good idea to post your new results link.  


Ryzen 5 3400G | MSI B450M Pro-M2 MAX | 16GB Corsair Vengeance DDR4 3000 | XPG SX8200 Pro 512GB NVMe | Windows 10 Pro

I ran a few and still not getting enough service to access my remote desktop.  I haven't been able to access at all this week.  Getting very, very frustrated.  I upgraded my plan yesterday thinking it would work with improved upload speeds of 2Mbps but no.  I need some sort of solution. 

Hughesnet is currently investigating issues with RDP performance issues...  However, I think those issues are only on Gen5.  

If you are on Gen4 Pro Plan, the maximum upload speed is 2Mbps, however, you will likely see lower.

Not sure how you upgraded to a Gen4 Pro plan, as all Gen4 plans have been retired from my understanding.


Not sure how you upgraded to a Gen4 Pro plan, as all Gen4 plans have been retired from my understanding.

 

What???? I went to shop/upgrade, plans & pricing and upgrading yesterday.  I was billed for the difference.  What exactly does it mean my plan is retired?  Did my service level drop so I have to switch to Gen 5? 

 

I was perfectly fine last week working via my RDP on the plan I was on.  I thought upgrading would have improved my performance because the plan was "up to" 2Mbps instead of 1.  I can connect via my VPN but get no where via the RDP connection.  My IT guy can't get anything but "time outs".  I even got up at 4:00am this morning to try to access.


 

Hrm...  @Liz might have to look into the service plan thing...  As far as I know, the only upgrade options offered to anyone anymore are Gen5 service plans.

Am new to HughesNet as of yesterday so first full day working from home.  It just took me 34 minutes to upload a 16mb file.  I have to do that several times a day.  This kind of upload speed will not work for what I need.  Hopefully that's not what I should expect day to day. 

GabeU
Distinguished Professor IV

@txbeld

 

If you'd like help with your speed issue, please create a new topic to keep your issue separate from the OP's.  


Ryzen 5 3400G | MSI B450M Pro-M2 MAX | 16GB Corsair Vengeance DDR4 3000 | XPG SX8200 Pro 512GB NVMe | Windows 10 Pro

Any solution suggestions?  Should I try changing out the cables, new router, new computer?  I reboot, reboot, reboot.  Day 5 and still can't work from home. I can't continue driving places...I have Hughesnet because I'm rural.  Should I upgrade again to a business account? 

@kelley.nesbitt5

 

What modem do you currently have, and so I can easily figure out your service plan, what is your maximum Bonus Bytes and Anytime Bytes bucket size? 10/50? 20/50? 30/50? 50/50? 15/50? 5/50?

 

What are you using for your RDP session?  Are you using Remote Desktop Connection that's available in Windows?  If you are, try clicking on the Experience tab, and change the field highlighted in red in the image below, to "Satellite"

RDP Settings.png


Aside from that, can you follow the below procedure and share your testmy.net results link with us?  Since we are troubleshooting your upload concerns, you will need to make sure you're performing upload tests and not download tests.

Please keep in mind that Hughesnet will only accept testmy.net and the official Hughesnet speed test results. Tests from other sites like speedtest.net are not accepted due to the compression technologies and latency that satellite deploys.  It is best to create a testmy.net account, that way you can keep a record of all your tests.  Please make sure you are logged into your testmy.net account when doing tests there so that engineering can easily find your result history.

Most important points to remember during this test:
-do the tests while directly connected to the HughesNet modem with a LAN cable (NO third party Router or Wireless devices can be used)
-use the 12MB size download test file ONLY if on Gen4 Service Plan
-use the 25MB size download test file ONLY if on Gen5 Service Plan

-If testing upload instead of download, you must use a 4MB size upload test file
-space each test at least 5 minutes apart
-post your results URL here, it may look something like http://testmy.net/quickstats/C0RR0SIVE


For a more in depth guide on running the tests, please visit: http://customer.kb.hughesnet.com/Pages/7001.aspx

@C0RR0SIVE

 

I changed the RDP setting but no change.  I have HT1100, I just upgraded to the Gen 4 Pro plan with 15/50.

 

I tried pinging to the remote computer and still time out, 100% loss. 

 

What's odd is that even when I have been out of my anytime data, I've been able to remote in. 

 

I'll post speed tests in a bit after I run a few.

Can you run a tracert to the remote computer to see where the connection is dropping out out and share a screenshot of the results with us?

@C0RR0SIVE

 

Not tech saavy, how do I do that?

tracert.png

Are you on a VPN connection when running that tracert?  If so, it's not going to give any results that are usable, and VPN's aren't supported on Hughesnet.

I can't access remotely without the VPN.  Hasn't been an issue except every once in a while.  When I signed up for service 7+ years ago, I was told the VPN would work and that is why I went with Hughesnet rather than other satellite providers.

 

The ping cannot locate the host now because I disconnected from the VPN.

I will tell you that things were fine last week.  Over the weekend, I got the javascript error on the status meter and found the information here to fix. Not sure if that would have anything to do with it, just a thought.

" I can connect via my VPN but get no where via the RDP connection."

Maybe I misunderstood the comment?  Thought that you could connect using RDP via VPN, but couldn't connect via RDP with out VPN.

@C0RR0SIVE

 

My VPN connection connects

My RDP does not

 

Sorry, can't get screen shot to work on this.

vpn.png

 

 

OK... so you have been able to connect via RDP with out the VPN in the past, correct?  If yes, try running a tracert to the address you was using with RDP, as that may/will shed some light if your answer was yes...

Or have you always had to connect to your VPN in order to use RDP?  It's a miracle that VPN has always worked for you as it usually doesn't for most, but the moment you add RDP on top of a VPN, there's too much overhead due to encryption for it to be feasible on satnet, so it wouldn't surprise me it's not working, though, I have no idea why it would in the past.

Those speedtest results might still be needed as they may provide some insight.