cancel
Showing results for 
Search instead for 
Did you mean: 

Usage Meter

anniebouscal
Freshman

Usage Meter

Usage Meter will not run on my Win 7 HP. Called tech support, no resolution.  Does  it provide any additional functionality or value? I gave up on trying to get it to run because tech said it is the same as MyAccount/Usage which provides nothing beyond a couple number and the opportunity to buy tokens.     

 

I also tried to download Glasswire but received the 404. I am assuming this is the result of my    e  x  t  r  e  m  e  l  y    s  l  o  w    connection I will try again tmorrow after my account refreshes.  

8 REPLIES 8
MarkJFine
Professor

Re: Usage Meter

Can you be more specific re: will not run? E.g.: does something install? Does no green or blue donut ‘icon’ appear anywhere? If you clicked on the donut icon does it show a window?


* Disclaimer: I am a HughesNet customer and not a HughesNet employee. All of my comments are my own and do not necessarily represent HughesNet in any way.
GabeU
Distinguished Professor IV

Re: Usage Meter

A 404 error being caused by a slow connection would be a bit unusual, at least in my experience.  Are you sure you're using the correct address for Glasswire?  

 

https://www.glasswire.com/

 

The Usage Meter issue doesn't happen to be related to a pop up box that mentions something about JavaScript, does it?  


Ryzen 5 3400G | MSI B450M Pro-M2 MAX | 16GB Corsair Vengeance DDR4 3000 | XPG SX8200 Pro 512GB NVMe | Windows 10 Pro
jacilewis3
New Member

Re: Usage Meter

It appears to be downloaded but when I click on it, the install window appears and the installation starts but will not complete.  No error messages.

MarkJFine
Professor

Re: Usage Meter

@jacilewis3

For which operating system?


* Disclaimer: I am a HughesNet customer and not a HughesNet employee. All of my comments are my own and do not necessarily represent HughesNet in any way.
DonB
New Member

Re: Usage Meter

I'm running windows 10 and I get a java script error from the usage meter app everytime I boot up 

Tags (1)
MarkJFine
Professor

Re: Usage Meter

@DonB

The OPs problem with the Usage Meter sounds like an installtion issue. Yours is different. Here's how to fix it:

 

Under some circumstances, the configuration and cached information that the Usage Meter needs to operate gets corrupted.

In the event that this happens:
1. Fully quit the Usage Meter from it's own menu by clicking on the donut in the menubar and clicking "Quit".
2. Look for the following directory
   Windows: C:\Users\[your User name]\AppData\Roaming\
   Mac: /Users/[your User name]/Library/Application Support/
3. Carefully delete just the "HughesNet Usage Meter" directory under that and empty the trash.
4. Restart the Usage Meter. This will regenerate all the underlying information as if it were run for the first time, thus correcting the error.

Disregard other recommendations that say to uninstall and reinstall the app and/or update Java as those do absolutely nothing to fix the problem. Uninstalling doesn't delete the directories above. Likewise, the application is written in JavaScript which is completely separate from Java, which of itself is a stand-alone runtime environment.

The only reason you should possibly uninstall something is if you are not running the current version, have inadvertently deleted part of the application, or have the older "HughesNet Status Meter" still installed. Uninstalling the older Status Meter and using the most recent version of Usage Meter is highly recommended.


* Disclaimer: I am a HughesNet customer and not a HughesNet employee. All of my comments are my own and do not necessarily represent HughesNet in any way.
anniebouscal
Freshman

Re: Usage Meter

I had a tech rep call to disxuss this and we found a Satus Meter cfg file which apparently did not get deleted by the new Usage Meter. After deleting that file and uninstalling / reinstalling the Usage Meter (at the insistence of the rep), there was still no response to the desktop icon. I am supposed to hear back.  I will look into your recommendation as time allows. Thanks for the response.

smmaharriman
New Poster

Re: Usage Meter

Thanks for posting this solution.  It worked for me.  One caveat, I had to go to Folder Options in the Control Panel to turn on the display of hidden folders and files to see the Appdata folders. I noticed that all of the files in the HughesNet folder were all dated from when we first purchased HughesNet about 10 months ago.   

 

I had called Hughes Net support, but they were of no help.  The person just had me try to reinstall the Usage Meter again and when it didn't work said they couldn't understand why.  No further escalation, just have a nice day.  Anyway, glad I searched the Community pages and happened on your solution.