cancel
Showing results for 
Search instead for 
Did you mean: 

Very low Gen 5 wireless data rate on my Toshiba laptop but not other laptops?

New Poster

Very low Gen 5 wireless data rate on my Toshiba laptop but not other laptops?

I have a Toshiba Portege R930 running Windows 10.  It's has a i7 procesor and solid state drive so it is much faster than the other laptops my family uses.  When I run Testmy on the Toshiba at home over a DSL router I get blazing rates but not at my cabin that has Gen 5.  However, my family's other computers work fine with Gen 5.  For example, when other laptops my family uses get 3Mbps on Gen 5 wireless using Testmy, my Portege gets 100Kbps!  Any ideas?  I've updated all the drivers and disabled all power saving.  Don't understand why it works fine on DSL wifi but not Gen 5 wifi.

6 REPLIES 6
Associate Professor

Re: Very low Gen 5 wireless data rate on my Toshiba laptop but not other laptops?

Are you using the 2.4Ghz band or the 5Ghz band?  How far are you from the HT2000w when testing?

1: Visit http://192.168.0.1
2: Click on "Wifi Settings"
3: Password is admin by default
4: Navigate to Advanced Setup > Wirelss

What do you see for Wireless Mode, Channel, Extension Channel, and Bandwidth ?

New Poster

Re: Very low Gen 5 wireless data rate on my Toshiba laptop but not other laptops?

The data rate does not change irrespective of distance to the Gen5 receiver.  I can be in the same room as the receiver or the other side of the cabin.  Portege performance is the same on 2.4 and 5.  Other family computers have good data rates but the Toshiba Portege is crap so I am sure it is not a problem with the Gen 5 wireless.  Plus I havenot changed any of the default Gen5 settings.  I can't answer your other questions because I have returned from my cabin so I can't access the receiver.  Is there some wireless setting I should look at on the Portege?  Remember, the Portege works fine on my home DSL wireless.

Assistant Professor

Re: Very low Gen 5 wireless data rate on my Toshiba laptop but not other laptops?

Latest wireless adapter drivers? Many times the ones posted on the manufacturer website are outdated, especially for laptops. What make/model adapter is in you laptop?

 

If WIndows OS then System>Device Manager>Network Adapters will tell you what adapter you have.

Associate Professor

Re: Very low Gen 5 wireless data rate on my Toshiba laptop but not other laptops?

There's a lot of wireless settings in the modem that could in theory improve performance, the fact it's affecting only that machine is odd, hence why I asked what settings are set to in the HT2000w.

Your laptop wasn't connected to any sort of VPN was it?

Highlighted
New Poster

I'm now wondering if this is not a pervasive problem with the Gen 5 wireless

To answer the latest questions.  One of the first things I did was check the driver firmware revision for all network adapters and update if necessary.  One that I updated was the wireless device Intel Centrino Advanced-N 6235.  Updating had not effect.  I did not do an "uninstall" and re-install".  Most of the various drivers were already using the newest version.  I don't understand the comment that the manufacturer may not have the latest version information.  If Intel does not have it then who does?  No the computer has not been used in a VPN.

 

I co-locate the Toshiba next to another laptop and run speed tests side by side.  I have never had a speed problem with the Toshiba on the 4 routers I have owned at home or at my cabin in the past few years or with any other network when I travel.

 

Thinking about this more, I remember that I had to replace some devices (an older Panasonic home video camera and a Canon printer) because both refused to connect with the Gen5 receiver wifi.  (The Gen 5 receiver is using factory default settings)  Also, before I realized that the problem was only with one of my computers (I am the primary computer user in the family.  My wife uses it rarely) I had the Gen 5 receiver replaced with no change in performance.  However, all of these systems (Toshiba, printer, camera) worked fine with my Gen 4 hooked to a Linksys wifi router before I was "upgraded" to Gen 5.

 

Then I see lots of complaints on this board of folks having similar data rate issues on Gen 5 with speeds around the 100Kbps I am seeing and I now wonder if there is a chronic issue with the Gen 5 wireless router design (ethernet connection works fine) that most of us are seeing.  For example, perhaps the backward compatibility of the Gen 5 wireless router protocol is not as robust as it should be.  That is, perhaps it does not work properly if the device I am trying to connect to the Gen 5 router is using something older than 802.11n (b or g for instance).  It is obvious to me that the problem lies in Gen 5 and not in my Toshiba laptop since Gen 5 is the only wireless router I have ever had a problem with.  This is something that Hughes should investigate further.  Try connecting Gen 5 to an array of older devices rather than take the manufacturer's word that it is backward compatible because they tested it in a lab using test equipment and not real world devices.

 

Since I can't do any more experimentation until I return to my cabin.  We should kill this thread and I'll renew it when I return to my cabin next month.  Any suggestions on what I should change or look for in the Gen 5 wireless router when I get there would be appreciated.

 

Associate Professor

Re: I'm now wondering if this is not a pervasive problem with the Gen 5 wireless