cancel
Showing results for 
Search instead for 
Did you mean: 

Very slow download speeds on certain services

Freshman

Very slow download speeds on certain services

My problem began around the time the HughesNet Gen5 modem was updated to application saftware version 3.4.6.25 and Wi-Fi software version 0.10.10 which seemed to have introduced new IPv6 settings and forced it on. Speed tests would indicate I should have absolutley zero problem donwloading when I have data but the actual speed I get is barely better than Dial-Up, however this only seems to be slow with donwloads on certian services like Playstation Network, Microsoft's Windows store and Google Play store, which has never been an issue till now. I've tried multiple things but nothing has worked and I'm at a complete loss. The only thing I can think of is that the IPv6 settings seem to be conflicting with those services specifically, while others are just fine. For example Blizzard's Battle.Net Desktop App had an update around 25MB and was done in seconds and clearly was not having issues the other services I listed are having. Any help on this matter would be greatly appreciated.

 

UPDATE: Issue seemed to resolve on it's own, don't know the cause but everything is now back to normal.

1 REPLY 1
Highlighted
Distinguished Professor IV

Re: Very slow download speeds on certain services

@CubeOfWater 

 

It's possible that the problem was/is somewhere along the route to the servers.  More and more often things seem to be happening that are related to providers down the line.  Century Link is one often mentioned.  One minute a download or update can be going just fine, then it slows to a crawl, then back again the next.  I have a feeling that some of these providers are overly sensitive to the high latency inherent to satellite internet, as well, which can add to the problem.


AMD Ryzen 5 3400G | XPG SX8200 Pro 500GB M.2 NVMe SSD | Western Digital Blue 500GB HDD | 16GB Corsair DDR4-3000 | Windows 10 Pro 64-bit