cancel
Showing results for 
Search instead for 
Did you mean: 

Vista drivers Gen 5

eagle1963
New Poster

Vista drivers Gen 5

I recently switched to Hughesnet gen5 from another provider.  All is well except for my wifes desktop computer running Vista.  As long as it is hardwired to the netgear router I was using with the previoous provider and the netgear is connected to the modem, all works fine.  If I connect directly to the modem, Vista does not recognize the network or able to get to the internet.  Reconnecting to the router makes everything work fine.  I tried various solutions but not worked.  I taked to a tech at BestBuy and he said that it is a driver problem. That Vista does not have the drivers for the new gen 5 modem thus not being able to see the new device and connect out.  I wish to be able to connect to the modem so the other computers on the network can see the Vista machine.  Thought, ideas or suggestions until I can find a replacement of the software on the Vista machine.

8 REPLIES 8
BirdDog
Assistant Professor

Re: Vista drivers Gen 5

Good luck. Vista is pretty much a dead unsupported OS. HughesNet, or any other ISP, will not go out of their way to fix any problems with it.

 

Honest opinion and reply. May not be the one you wanted.

 

Could try changing the security protocols between the modem and her computer.

 

 

C0RR0SIVE
Associate Professor
BirdDog
Assistant Professor

Re: Vista drivers Gen 5


@C0RR0SIVE wrote:

@eagle1963
When you say "connect directly to the modem" do you mean via network cable, or via wifi?


May be misreading but getting the impression it works when the Vista computer goes through the router but not when connected directly to the Hughes modem. Makes sense as the router is acting as the security and firewall, compensating for outdated Vista protocol.

 

@eagle1963 you may want to have the wife read this: https://support.microsoft.com/en-us/help/22882

 

Personally, I'd upgrade to Windows 8.1 before 10 though. It is supported until 2023. Legitimate licenses can be had pretty cheap these days.

eagle1963
New Poster

Re: Vista drivers Gen 5

Yes connected with a network cable not wifi.

GabeU
Distinguished Professor IV

Re: Vista drivers Gen 5

@eagle1963

 

I had a similar issue with an old Dell desktop when I reinstalled the Vista that it came with (I had "upgraded" it to Linux Mint).  It would connect, but the speed was awful and it kept dropping out (yes, it dropped out when directly connected).  Nothing could fix it.  

 

Vista, unfortunately, is just too outdated to work properly.   Not only that, but it's also now outside of it's extended support cycle, meaning it no longer receives security updates, and is therefore vulverable.  

 

The only option you have in the interim is running it through the Netgear router, though that's not going to alleviate the core issue of you wanting it networked (in the immediate).  If it came with Vista, it will most likely at least meet the minimum system requirements for Windows 8.1, but make sure.  

 

Edit: To add, though, perhaps someone can help with setting up the computer through the router so you can still have the networked setup you wish.  I'm not familiar enough with Networking to say whether than can be done or not.  Others are.   


Ryzen 5 3400G | MSI B450M Pro-M2 MAX | 16GB Corsair Vengeance DDR4 3000 | XPG SX8200 Pro 512GB NVMe | Windows 10 Pro
Gwalk900
Honorary Alumnus

Re: Vista drivers Gen 5

@eagle1963

 

There are no "modem drivers". My wife's Vista laptop has no issues connecting both wired and wireless.

There are issues related to the proper WAN/LAN port connections as well as resolving potential IP address conflicts.

 

The Hughes Modem has to have the IP address of 192.168.0.1 reserved for its own use.

 

The Router needs to have its LAN IP set to 192.168.1.1 so as to avoid conflict with the Modem.

 

Post the model and version number of your Netgear router.

 

Make all settings changes with a wired computer, not wireless.

 

The first step I would take is to connect a computer directly to the Hughes Modem #1 LAN port. No Router connected.

Open the Modems GUI and turn off the wireless functions, 2.4 and 5 ghz including guest accounts.

Disconnect the computer from the modem.

 

Next connect a wired computer directly to one of the Routers four LAN ports

Open the Routers GUI and set the Routers LAN IP to 192.168.1.1

Save the changes,

 

Power off the Modem, Power off the Router, power down the computer.

 

Connect an Ethernet cable from the #1 LAN port of the Hughes modem to the WAN port of the Netgear Router

Connect another Ethernet cable from the #1 LAN port of the Router to the Ethernet port of one of your wired computers

 

You should now look like this. Take careful note of WAN and LAN connection ports

Connections.png

 

When complete, do the following, in order:

 

Power up the Hughes Modem. Let it boot up completely before continuing

Power up the Netgear Router, let it also boot up completely.

Finaly power up the Computer

 

Connection check:

Open a browser, enter 192.168.1.1

This should take you to the Routers GUI log in page

 

Enter 192.168.0.1

This should take you to the Modems GUI

 

Log into the Router and make sure that DHCP is enabled.

 

We will at that point likely take and post some screenshots of your Router settings so as to aid in setting up Router secuity and then finally wireless connection settings.

 

 

 

eagle1963
New Poster

Re: Vista drivers Gen 5

I have a vista laptop that works fine directly connected to the hughesnet modem with an eithernet cable.  It is her desktop that running vista that does not see the hughesnet network.

GabeU
Distinguished Professor IV

Re: Vista drivers Gen 5


@eagle1963 wrote:

I have a vista laptop that works fine directly connected to the hughesnet modem with an eithernet cable.  It is her desktop that running vista that does not see the hughesnet network.


The fact that it will connect to the router, but not to the modem, is most definitely odd.  I hadn't connected my desktop in over two years when I had Linux Mint on it, and when I installed Vista and it wouldn't connect it may very well have just been the MB taking a dive.  

 

That it's not connecting makes me think it's more something with the computer itself and doesn't necessarily have to do with Vista.  Yours is the first instance I've read of on the Hughesnet Community of a desktop not connecting to Gen5 when using a LAN cable.  It may be that it wouldn't connect even if you upgraded to Windows 8.1.  Who knows?  My original build desktop, which I built in 2005, and just installed XP on for the first time in years, connects just fine.  I have no plans on keeping it connected as it's only going to be used for playing old games that I can't play on the desktop I am on now, and it's also vastly outdated when it comes to security, as is Vista, though considerably moreso, but still, it connects.  

 

Perhaps you could try uninstalling (through Windows) and then reinstalling the netword adapter.  Maybe this will jog it a little and get it to work properly.  

 

Is the desktop in question a home build or a brand name?  If a brand name, what make and model is it?  There really aren't any "Gen 5" drivers.  The drivers for the network adapter are for everything it can connect to, and the HT2000W shouldn't be giving it a problem.  

 

And, though it's already been said in this thread, including by me, you really ought to upgrade that OS.  I hope you don't use either that desktop, nor your laptop with Vista, for anything personal or financial on the net.  Vista can no longer be said to be secure.  


Ryzen 5 3400G | MSI B450M Pro-M2 MAX | 16GB Corsair Vengeance DDR4 3000 | XPG SX8200 Pro 512GB NVMe | Windows 10 Pro