cancel
Showing results for 
Search instead for 
Did you mean: 

Web pages slow to load

Highlighted
JCH
Freshman

Web pages slow to load

Been a Gen5 customer for some time now with generally satisfactory results. However, past coupe of months or so I have experienced varying problems with web pages loading slowly as well as much buffering of YouTube videos.

Windows 10 PC connected via ethernet. Android phone and tablet connected via WiFi. Same prolems with  all devices.

Speed tests from PC with WiFi off:   https://testmy.net/quickstats/hjerald1

Seems upload speeds slow?? 

Rebooted modem, video saver off.....no improvement.  Signal strength varies in 73-92 range. Dish tight and stable with no obstructions. Sometimes web pages load just slow, other times painfully slow.

Hoping for some suggestions.

14 REPLIES 14
Professor

Re: Web pages slow to load

Seems your modem is getting good speeds both up and down. Do you maybe have updates that are needed for your PC? Have you also cleared the cache for your browser(s)?

 

Edit:  You may also want to try the DNS-clearing procedure outlined by Mark, here:  https://community.hughesnet.com/t5/Tech-Support/Safari-can-t-connect-to-server/m-p/115627/highlight/...

 

Others may have better suggestions.

 

JCH wrote:

Been a Gen5 customer for some time now with generally satisfactory results. However, past coupe of months or so I have experienced varying problems with web pages loading slowly as well as much buffering of YouTube videos.

Windows 10 PC connected via ethernet. Android phone and tablet connected via WiFi. Same prolems with  all devices.

Speed tests from PC with WiFi off:   https://testmy.net/quickstats/hjerald1

Seems upload speeds slow?? 

Rebooted modem, video saver off.....no improvement.  Signal strength varies in 73-92 range. Dish tight and stable with no obstructions. Sometimes web pages load just slow, other times painfully slow.

Hoping for some suggestions.


 

JCH
Freshman

Re: Web pages slow to load

Thanks for the reply. The PC is up to date and I have cleared the browser cache. I've  also done much work on the PC using Google search results with no improvement. I am concluding that my problem is not the PC. Also slow loading web pages occur using WiFi on my phone or tablet also suggesting that it is not a device problem.

P.S. I just tried the DNS clearing following the link you provided, but again no improvement.

Moderator
Moderator

Re: Web pages slow to load

Hi JCH,

 

I'm glad you found the community, thank you for posting your troubleshooting steps so far, this helps. I ran diagnostics on your site and see that the HughesNet equipment is working normally. Does the slow page loading persist in multiple web browsers? Does using an adblocker on your preferred browser make a difference in page load speed? 

Thanks,
Liz

Did my post answer your question? Accept as Solution to help others find it faster.--------------------------------->

JCH
Freshman

Re: Web pages slow to load

Thanks for the reply Liz,

I use Edge browser with AdBlock. No difference in page loading with adblock off.

Tried Internet Explorer 11 (no ad block). No obvious difference in web page loading speed compared with Edge.

However, there is abiguity in web page loading speeds (determined visually). Some times pages will load quickly but then, on the next try, be quite slow.

Quick loading can last for a minute to several minutes or even more, then can slow, sometimes dramatically and remain slow for varying lengths of time. I have noticed this phenomenon during morning, afternoon and evening sessions.

YouTube videos almost alway show some to very serious buffering.

Moderator
Moderator

Re: Web pages slow to load

Interesting, how about Chrome or Firefox?

Thanks,
Liz

Did my post answer your question? Accept as Solution to help others find it faster.--------------------------------->

JCH
Freshman

Re: Web pages slow to load

Well, I downloaded Firefox then Chrome to give them a try. 

No obvious differences noticable over Edge or IE.  

Makes some sense, I guess, as Gen5 worked with Edge until the last couple of months or so? 

 

P.S. As I am typing this I have checked serveral websites (using Edge) that I commonly use and they are all popping right up. Likewise with a couple of random YouTube videos......no buffering at all.

Here are the results of a speed test I just completed after the above checks....

https://testmy.net/results

Moderator
Moderator

Re: Web pages slow to load

Hi JCH,

 

The link isn't sending me to your results, can you double-check your result link? Are you saying that the issue cleared up on its own now?

Thanks,
Liz

Did my post answer your question? Accept as Solution to help others find it faster.--------------------------------->

JCH
Freshman

Re: Web pages slow to load

https://testmy.net/quickstats/hjerald1 (last point is just now results result).

Yes, things are faster now. But this has happened in the past and then they have slowed down again.

We will see what happens as the hours pass.......

JCH
Freshman

Re: Web pages slow to load

Some more info liz,

Latency test from testmy.net;

The delay values seem quite long even for satellite? 

2019-10-23 14:14:53
Los Angeles, CA | 990.65 ms | deviation: 38% (380.00 ms) |
2019-10-23 14:14:50
San Francisco, CA | 967.12 ms | deviation: 39% (376.40 ms) |
2019-10-23 14:14:46
New York, NY | 1201.86 ms | deviation: 67% (804.60 ms) |
2019-10-23 14:14:43
Miami, FL | 1551.93 ms | deviation: 72% (1.1 ms) |
2019-10-23 14:14:37
Colorado Springs, CO | 1576.64 ms | deviation: 68% (1.1 ms) |
2019-10-23 14:14:34
Dallas, TX | 1823.65 ms | deviation: 47% (865.70 ms)