HughesNet Community

YouTube/Amazon streaming buffering/stalling

cancel
Showing results for 
Search instead for 
Did you mean: 
BirdDog
Assistant Professor

YouTube/Amazon streaming buffering/stalling

Amazon seems to be suffering the same problem as YouTube lately. Have run some tests and my observations are as follows. There's been a number of complaints here about it so thought I'd do a bit of investigating and discovered the same issue.

 

Streaming starts out fine but then about two minutes in it buffers and I get the "bandwidth may be too slow" popup error. I'm on Gen 4 with good speed, 20-30 Mbps much of the time, and during the times I tested this.

 

Been watching my bandwidth throughput meter when checking. The video initiates and loads the cache on the computer, or TV, for the first minute or two minutes of viewing but then the throughput drops to zero or near zero. Once the cache drains then the video stops/stalls and starts buffering again, the throughput goes up from zero starting to load the cache but by then it is too late as the server end (Amazon/YouTube) thinks either the connection has been lost or the bandwidth is too slow and the error appears.

 

The problem seems to be something in the communication between client and server when it comes to the caching and it is not refreshing/filling ahead of time to keep up with the stream. It appears to be a satellite system to the video server communication problem and has been going on for awhile now. I even tried increasing the cache size on my Chrome browser but that didn't help, just extended the time a bit until it times out, drops to zero caching download. It is like a "keep alive" or similar signal is not being communicated between the streaming server and HughesNet client.

 

If I test Netflix streaming during the same period, it works fine, cache is continually updating. So it really does seem to be a communication thing between the Amazon/YouTube servers and HughesNet. It used to work fine just like Netflix some time back, but has really gone bad the last few months or so.

No idea which side the problem is on but there defineitely is a problem.

 

Pretty sure it is not fixable on the user end, will probably take engineering looking into it and until enough people complain here it may not get looked at period. Get the same results with Video Data Saver and Web Acceleration turned off.

 

Perhaps someone on HughesNet side can check it out and see if they get the same result? It sure seems like there is a breakdown in the communication between the streaming servers and user end over the HughesNet system.

 

 

 

22 REPLIES 22