cancel
Showing results for 
Search instead for 
Did you mean: 

browser speeds slow

Highlighted
New Member

browser speeds slow

I have fast speeds everytime I run any of the speedtest apps....but my browsing experience is slow...What could be the problem...Please help as I am a new customer..
8 REPLIES 8
Highlighted
Distinguished Professor IV

Re: browser speeds slow

Does the slow browsing happen all the time, and with just about any site you go to?  Does it happen with all of the browsers you have tried (if you have more than one)? 

What Operating System and browser are you using?  Are you directly connected to the modem with a LAN cable or are you using a wireless router?   

It could be caused by a lot of things, but the first thing I would make sure of is that your computer is "clean", as in free of malware and viruses.  Hopefully you have an antivirus program on your computer.  Many also detect and clean malware, but a very good supplement to the malware part is Malwarebytes.  It's free, and it can detect a lot more malware than most antivirus programs. 


https://www.malwarebytes.com/


Also, just as a heads up, Malwarebytes can take a seemingly long time to update when using Hughesnet.  I don't know why this is, but I suspect it has something to do with the high latency inherent to satellite internet.  Mine sometimes takes up to around ten minutes before it will finally "catch" and download an update. 



AMD Ryzen 5 3400G | XPG SX8200 Pro 500GB M.2 NVMe SSD | Western Digital Blue 500GB HDD | 16GB Corsair DDR4-3000 | Windows 10 Pro 64-bit
Highlighted
Assistant Professor

Re: browser speeds slow

Adding to what GabeU posted browsing may seem slow if coming from cable due to the higher latency of satellite. One thing to do is install an ad blocker on browsers, it speeds things up.

When you say speedtest apps from where are they and can you post some results? Only tests Hughes recognizes for troubleshooting are their own and Testmy.net.
Highlighted
Distinguished Professor IV

Re: browser speeds slow

Actually, I should have asked this question first:  When you say that your browsing experience is slow, do you mean that it takes a little bit of time for the browser to start opening the page, or do you mean that it takes the page a long time to open? 

The latency inherent to satellite internet can make it take a second or two for the browser to even get to a page to start opening, and if coming from a land based ISP, which has latency that is almost unnoticeable, it can seem like there is something wrong, as mentioned by BirdDog.   If the page is actually taking a while to open, that's another story. 

Again, I should have asked this question in the first place.   


AMD Ryzen 5 3400G | XPG SX8200 Pro 500GB M.2 NVMe SSD | Western Digital Blue 500GB HDD | 16GB Corsair DDR4-3000 | Windows 10 Pro 64-bit
Highlighted
Assistant Professor

Re: browser speeds slow

You're sure hard on yourself. None of us think of every question or fact about satellite internet first time around when someone posts. It is a process as the infamous "Chicken" says.  Smiley Happy
Highlighted
Distinguished Professor IV

Re: browser speeds slow

The infamous "chicken?" 

AMD Ryzen 5 3400G | XPG SX8200 Pro 500GB M.2 NVMe SSD | Western Digital Blue 500GB HDD | 16GB Corsair DDR4-3000 | Windows 10 Pro 64-bit
Highlighted
Assistant Professor

Re: browser speeds slow

Gwalk of course...lol. I'm done for the night. But:

We all contribute pieces which hopefully result in a solution. Kind of a team thing we have going here. Why I keep coming back. The reps really don't have the time to get into some of the little details we do.

I'm retired so probably spend more time here than I should but I'm good at multi tasking. I'll do things here at home then check in to the site every so often. Hey, I get enjoyment from it, sicko that I am.

You contribute a lot here Gabe, don't dog yourself. (get it, dog) I think I'm a comedian sometimes. Have a good night!

Dang always editing because of typos!
Highlighted
Distinguished Professor IV

Re: browser speeds slow


AMD Ryzen 5 3400G | XPG SX8200 Pro 500GB M.2 NVMe SSD | Western Digital Blue 500GB HDD | 16GB Corsair DDR4-3000 | Windows 10 Pro 64-bit
Highlighted
Alum

Re: browser speeds slow

Hello sdrake,

Thanks for posting and welcome to the community! GabeU and BirdDog have given some great suggestions thus far. Were they able to help what you are experiencing? I'm sure with a bit more info we can better assist you as well. Hope to hear from you soon.

Thank you,
Chris