HughesNet Community

"Check your connection error" on Secure Site Sign in

Showing results for 
Search instead for 
Did you mean: 

"Check your connection error" on Secure Site Sign in

  My Laptop, an Asus tablet, and a Windows tablet all get the above error when I try to sign in to  They all have connected fine until Feb. 22. 

  All use a different browser, Chrome, Bing, Windows Edge.

  All are using Hughesnet.  My daughter can connect to my account from her home (not Hughesnet). If she tries to connect on her phone from my WiFi she gets the same error message.  ERR_CONNECTION_RESET.  I have tried to connect with Firewalls, and Antivirus disabled.. I reset my modem several times.    

  Nothing works.  The only thing all these errors have in common is HUGHESNET.  

My other Secure sites connect banks, email, quickbooks, etc.  

  I pay big bucks for this site,  PLEASE HELP...

Distinguished Professor IV



Try the following...


1.  Unplug the HughesNet modem.

2.  Clear the DNS cache from your laptop, ASUS tablet and Windows tablet.  Each may have a different method, so before doing any of this Google how to clear the DNS cache for each of your devices.  After clearing the cache from each one, shut it down.

3.  Plug the HughesNet modem back in, then wait at least five minutes before the next step.

4.  Turn your device(s) back on, access the net and try the site again.  


This should clear the DNS cache from your entire system, which may very well help.  If the system gets a bad DNS address, it can propagate to all of the devices (if they're networked), causing all of them to use the bad address.  


If this doesn't help, you may want to try using a public DNS on one of the devices, just to see if it makes any difference.  If the laptop is Windows based, it would probably be easiest to do it with that.  You can Google how to use Google's own DNS, if you want to try theirs (I use Google's instead of HughesNet's), or you can use these instructions.  If you use those instructions, I would use the "Control Panel" method.  I would also change both IPv4 and IPv6.  For Google's, the DNS addresses are....


IPv4 - and


IPv6 - 

2001:4860:4860::8888 and 2001:4860:4860::8844  (There's a double colon :: between the 3rd and 4th number sequence with each.  I mention that due to it being easy to miss).  

Ryzen 5 3400G | MSI B450M Pro-M2 MAX | 16GB Corsair Vengeance DDR4 3000 | XPG SX8200 Pro 512GB NVMe | Windows 10 Pro

I'll let you know if this works,  THANKS !!

DNS flush didn't work.  I still got "please check your internet connection and try again'", BOO HOO

Hello @Rita1,


Thank you for reaching out to us. The issue you are experiencing has been reported to engineering by a few customers and is currently being worked on. As of right now, we know the affected websites are AOL, Yahoo, and We have not received any reports of any other website experiencing this, so we do not believe the issue will spread. I will be monitoring their updates closely until it has been fixed. I will also post any concrete information here once available. While I do not have a specific day when this will be fixed, our completion time for issues such as this rarely takes more than a full business week. I do apologize for the inconvenience and I appreciate your patience.  



Thank you Damian !! 

I thought I was going Crazy!!!  I truly have tried everything on my end.  I almost threw my Computer out the window!!!  Please let us know, by this thread, when the problem is fixed.