HughesNet Community

View/Pay Bill without log another victim of SC upgrade

cancel
Showing results for 
Search instead for 
Did you mean: 
Gwalk900
Honorary Alumnus

View/Pay Bill without log another victim of SC upgrade

It seems that the view/pay without log is another victim of the latest upgrade.

I choose to pay my bill early in the form of a direct debit as a "advance payment".

It seems that this is no longer an option.

I did go to the old customercare.myhughesnet.com and was able to do it from there.

I can't say that this latest upgrade was a step forward.



39 REPLIES 39
BirdDog
Assistant Professor

Barbara agrees. 
Liz
Moderator
Moderator

Hi Gwalk, 

Thanks for bringing this up, I'll send over this feedback as well.

-Liz
If you have a tech or billing question and need help, please start a new thread in the appropriate board. Unsolicited Private Messages may not get replies.

Slow performance? Click me!

Liz
Moderator
Moderator

Wait, what about this?

If you have a tech or billing question and need help, please start a new thread in the appropriate board. Unsolicited Private Messages may not get replies.

Slow performance? Click me!

BirdDog
Assistant Professor

Yea, seems to work even for Barbara, she gets this after clicking on that:

Gwalk900
Honorary Alumnus

I did attempt to use that as I have in the past. Instead of opening up a webpage it spit up a pop up window that no longer included the advance payment option:


Instead we have this:

The account balance at that time was zero. Attempting to make a payment resulted in an error.

Liz
Moderator
Moderator

Aha, thanks for the screenshots. I can send these up.

-Liz
If you have a tech or billing question and need help, please start a new thread in the appropriate board. Unsolicited Private Messages may not get replies.

Slow performance? Click me!

BirdDog
Assistant Professor

Should have known the chicken wouldn't scream fowl without backup.
Gwalk900
Honorary Alumnus

Danged hound just needs to dig a little deeper 🙂


Liz
Moderator
Moderator

By the way, how are you getting to the old customer care site? www.customercare.myhughesnet.com doesn't work for me; it redirects to the hughesnet.com site.

-Liz
If you have a tech or billing question and need help, please start a new thread in the appropriate board. Unsolicited Private Messages may not get replies.

Slow performance? Click me!

Gwalk900
Honorary Alumnus

Works OK here,


http://customercare.myhughesnet.com/

What are they going to do ... kill it?


Liz
Moderator
Moderator

Crazy, I could've sworn I tried it without the www and got the same site. 


Well... they've been trying to kill that page for ages...

-Liz
If you have a tech or billing question and need help, please start a new thread in the appropriate board. Unsolicited Private Messages may not get replies.

Slow performance? Click me!

Gwalk900
Honorary Alumnus

For ... whatever reason ... not everyone has auto billing enabled. The Billing Department holds a special place in my heart.

The last dealings I had with them entailed a great deal of stomach acid and took the efforts of ECC to get resolved.

The "View/Pay without log in" as it was presented in the past allowed me to pay my bill early .... in the form of an Advanced Payment ....

Something that has worked very well for at least 10 years.

I simply can not, will not, go back to a system where I have to argue the fact that Hughes is not entitled to be paid twice per month with someone for whom English is not their native language.


knerkin2
Freshman

I had one of those experiences with HughesNet telephone support last evening the memory of which will last me to my dying thought. I have Hughes Voice, which I expect was the culprit. Support wants to know your phone number, either spoken or keyed. I tried keying in the number only to be rewarded with a voice verification that got to the last digit of my area code and then announced that it had encountered an error, please resubmit.  Tried three times, all failed, so I went to the voice option. I spoke my number as I normally do, with a slight pause between numbers. The voice verification repeated "11200000000354670000897 Is that correct?" I finally discovered that I had to speak the phone number really really quickly, and even then it took 3 tries before it understood my English-as-first-language pronunciation. I'm sure many wouldn't have the patience I did.
Liz
Moderator
Moderator

Hi Gwalk,

I just chatted with our billing expert who happens to be in the office today so I can bug her with more questions about this. So the advance payment is still available today, but your balance has to be at zero for the option to appear.

You mentioned you had a zero balance when you tried to do an advance payment, did you ever see the option pop up? If you have a zero balance and no advance payment option showing, can you please send me a screenshot of that?

If you run into any error, please cap that as well.

Thanks!

-Liz
If you have a tech or billing question and need help, please start a new thread in the appropriate board. Unsolicited Private Messages may not get replies.

Slow performance? Click me!

Gwalk900
Honorary Alumnus

Hi Liz,
I'm at work at the moment and tomorrow looks a little busy but I'll post some info as soon as I can.
Liz
Moderator
Moderator

No worries, I won't close this thread any time soon. 🙂

-Liz
If you have a tech or billing question and need help, please start a new thread in the appropriate board. Unsolicited Private Messages may not get replies.

Slow performance? Click me!

Gwalk900
Honorary Alumnus

Liz I attempted twice today to create a reply that illustrates the problem however when trying to access the new updated SC "view/pay without login" I get so far and get this:

That doesn't make for a very illustrative screenshot.

Needless to say this is with several browsers, several operating systems, a modem and router reset and a four letter prayer to the gods of computers and interwebs.

Sadly I'm out of time today and tomorrow starts at 5am.

 

 

Liz
Moderator
Moderator

Hmm, so when exactly does that error pop up? 

When I click on the View/Pay My Bill button on the Support Center, I get this prompt:

Do you get that far or does the error pop up after clicking the Continue button on this page?

Please let me know at your convenience, no rush.

-Liz
If you have a tech or billing question and need help, please start a new thread in the appropriate board. Unsolicited Private Messages may not get replies.

Slow performance? Click me!

Gwalk900
Honorary Alumnus

Finally the info.


In the past I could go to either the "old" SC:


OR the new Gen4 SC:


And click on the "view/pay without login" button

That would in either instance open the following window:


Entering my SAN, capcha info and selecting "make a payment" option yielded the following:


Answering the security question brought me to the following:

Because of past billing issues it was resolved that I have invoice billing and no "saved payment" method on file. That means that their is NO possibility of misunderstandings or errors/mistakes.

Even though I have invoice billing I still enjoy paying my bill online and I pay my bill early every month by using the "Advance Payment" option.

This has worked well for that last 10+ years.

(I use the e-Check option)

Entering the above information then brought the following screen:

I would then authorize the payment by clicking a "collect now" button and get the following conformation screen:


At that point I could then login and see that the payment did indeed "take" by noting that my former $0.00 balance now reflects a $89.99 credit balance:

Everybody was happy, Hughes got paid (early) and I was assured of no errors.


The situation changed however with the SC/Community "update".


Going to the revamped SC:


Clicking on the "view/pay without login" gives a popup:


Entering the info brings us to:

Account balance at the time would have been $0.00

Please note that there is no "Advance Payment" option.


Entering my desired early payment amount produces the following error:


I was able to make this months payment by going through the old SC.

Liz
Moderator
Moderator

Hi Gwalk, thanks.

I guess the connection was reset error is no longer an issue?

I will take your last screenshot of the "Your payment cannot be more than the current balance" message, and send that up, explaining that you got that message when you tried to click pay now despite having a zero balance.

As I understood from our billing expert, if you have a zero balance (not positive or negative), you can enter the amount you wish to pay in advance, and click the Pay Now button. The next page would then have an option to confirm this is an advance payment.

I haven't seen this myself, so I'm trying to reproduce this new process or at least get a screenshot of what is expected when doing an advance payment now.

Thanks,
Liz
If you have a tech or billing question and need help, please start a new thread in the appropriate board. Unsolicited Private Messages may not get replies.

Slow performance? Click me!