cancel
Showing results for 
Search instead for 
Did you mean: 

Amazon Issue - Occasionally Not Loading or Not Loading Correctly

Distinguished Professor IV

Amazon Issue - Occasionally Not Loading or Not Loading Correctly

I'm getting so tired of this, and I wish I could figure out why it's happening. I believe it has something to do with the TLS Handshake, as I can see that indication when trying with Firefox.  I also suspect that it may not only be a HughesNet problem, as in something may be happening with the Amazon site that causes HughesNet to go a little haywire with it, even though it doesn't seem to have the same affect when using other ISPs, including my TracFone.  

 

I've tried various DNS servers  I've tried turning of IPv6 altogether. I've tried disabling Web Acceleration.  I've tried flushing the DNS cache.  I've tried deleting the browser caches.  I've tried it on two different computers, one LAN and one WiFi, and I've tried it on my phone via WiFi (no problem with the phone when using its own connection).  I've also tried the various DNS servers in the modem's GUI.  I've power cycled the modem.  I give up.  All of a sudden it will just work, then, at any given time, it will fail again.   

 

Sometimes, after it finally works, the pictures and/or links on the site won't load properly.  

 

Chrome Failure...

 

Amazon Failing - Chrome.jpgAmazon Failure - Chrome

 

Firefox.  Attempting TLS handshake.  It will stay this way for at least 30 seconds...

 

Amazon TLS Handshake - Firefox.jpgAmazon TLS Handshake Attempt - Firefox

 

Firefox Failure...

 

Amazon Failed - Firefox.jpgAmazon Failure - Firefox 


AMD FX-6100 | Samsung 250GB 840 EVO SSD | Western Digital Blue 500GB HDD | 16GB DDR3-1866 | EVGA Geforce GTX 550ti | Windows 10 Pro 64-bit
14 REPLIES 14
Senior

Re: Amazon Issue - Occasionally Not Loading or Not Loading Correctly

I've had the same problems with Amazon.

 

Sometimes running the connectivity test will fix it. Sometimes restarting my surface tablet will fix it.

 

Maybe my fixes are just a coincidence. Don't know....

Distinguished Professor IV

Re: Amazon Issue - Occasionally Not Loading or Not Loading Correctly


@lake_woman wrote:

I've had the same problems with Amazon.

 

Sometimes running the connectivity test will fix it. Sometimes restarting my surface tablet will fix it.

 

Maybe my fixes are just a coincidence. Don't know....


Thank you for your suggestions.  Restarting my devices are a part of my procedure of power cycling the modem, but restarting them would make no difference because of where this type of problem lies (either HughesNet or Amazon).  Shutting down the device, then starting it after the modem power cycle, as referenced in the other thread, is so it starts with a fresh connection, and power cycling the modem while the device is still on will often create a problem between the device's network card and the modem.  

 

The Connectivity Test only tests, it doesn't alter or fix anything.  It just tests.  

 

The problem eventually corrects itself on its own.  

 

Happy now?  There's no reason for you to reply on another thread about your unhappiness for me not replying to your post on here.


AMD FX-6100 | Samsung 250GB 840 EVO SSD | Western Digital Blue 500GB HDD | 16GB DDR3-1866 | EVGA Geforce GTX 550ti | Windows 10 Pro 64-bit
Senior

Re: Amazon Issue - Occasionally Not Loading or Not Loading Correctly


@GabeU wrote:

@lake_woman wrote:

I've had the same problems with Amazon.

 

Sometimes running the connectivity test will fix it. Sometimes restarting my surface tablet will fix it.

 

Maybe my fixes are just a coincidence. Don't know....


Thank you for your suggestions.  Restarting my devices are a part of my procedure of power cycling the modem, but restarting them would make no difference because of where this type of problem lies (either HughesNet or Amazon).  Shutting down the device, then starting it after the modem power cycle, as referenced in the other thread, is so it starts with a fresh connection, and power cycling the modem while the device is still on will often create a problem between the device's network card and the modem.  

 

The Connectivity Test only tests, it doesn't alter or fix anything.  It just tests.  

 

The problem eventually corrects itself on its own.  

 

Happy now?  There's no reason for you to reply on another thread about your unhappiness for me not replying to your post on here.


Just curious... how many times have you been told that you are a jerk?

Professor

Re: Amazon Issue - Occasionally Not Loading or Not Loading Correctly

"I'm getting so tired of this, and I wish I could figure out why it's happening."

 

Ditto and ditto.  I've seen the issue more often lately.

Professor

Re: Amazon Issue - Occasionally Not Loading or Not Loading Correctly

What browser(s) are you using, and does it happen on all of them? Sometimes I change browsers and that fixes it, but not always, so it's likely not a browser problem.

Senior

Re: Amazon Issue - Occasionally Not Loading or Not Loading Correctly

FWIW I only use Firefox and this happens to me lately ...   last few months.  Got worse around Christmas to now. 

I think it just auto fixes itself for me as I have not tried anything to fix it.

 

Val

Professor

Re: Amazon Issue - Occasionally Not Loading or Not Loading Correctly

I usually use Firefox but when this started to happen I started to switch browsers to see if that helped. Helped sometimes, didn't others, so all in all, not too helpful. Smiley Happy

Distinguished Professor IV

Re: Amazon Issue - Occasionally Not Loading or Not Loading Correctly


@maratsade wrote:

What browser(s) are you using, and does it happen on all of them? Sometimes I change browsers and that fixes it, but not always, so it's likely not a browser problem.


I normally use Chrome, but I've tried Firefox, Edge, and even IE.  I suspect it's either an issue with HughesNet or something with Amazon that HughesNet doesn't like, or even the other way around, but whatever is causing it seems to be dynamic, as it almost always corrects itself within a half hour or so of happening.  

 

Last night it happened again, but that time a DNS cache flush seemed to fix the issue.  I wish that was always the case.  


AMD FX-6100 | Samsung 250GB 840 EVO SSD | Western Digital Blue 500GB HDD | 16GB DDR3-1866 | EVGA Geforce GTX 550ti | Windows 10 Pro 64-bit
Distinguished Professor IV

Re: Amazon Issue - Occasionally Not Loading or Not Loading Correctly


@val_t wrote:

FWIW I only use Firefox and this happens to me lately ...   last few months.  Got worse around Christmas to now. 

I think it just auto fixes itself for me as I have not tried anything to fix it.

 

Val


Yep.  Last night a DNS cache flush seemed to do the job, but most of the time it's just the "wait 'til it fixes itself" game.  And though, for me, it often does so within a half hour, a few times it's lasted for hours, unfortunately.  Smiley Sad    


AMD FX-6100 | Samsung 250GB 840 EVO SSD | Western Digital Blue 500GB HDD | 16GB DDR3-1866 | EVGA Geforce GTX 550ti | Windows 10 Pro 64-bit