Showing results for 
Search instead for 
Did you mean: 

Can't connect Xbox 360 to HT2000W

Can't connect Xbox 360 to HT2000W

hey folks,
So I recently moved to an area where satellite Internet is the only option. I went with hughesnet. I'm not super tech savvy at all, so this is baffling to me, but I have a HT2000W router (or modem, not sure what the difference is), and am having MTU error messages every time I try to get on xbox live. My 360 is able to connect to the network, and very rarely from the network to the Internet, but never from the Internet to xbox live. Does anyone out there who's had hughesnet or experience with them know what the problem is? And/or how to get around it? I've tried the wireless and hard-line option, but both are giving me the same error messages, and ultimately keeping me from being able to get on live. Any help would be appreciated. Need the help of a tech wizard who can explain solutions to me like they're explaining something to a 4 year old. Thanks.
Tags (2)
Associate Professor

Re: Can't connect Xbox 360 to HT2000W

Is your Xbox 360 being directly connected to the HT2000w?  
You don't have a third party router between it, and the HT2000w, do you?

What results do you get when you go to Settings > System > Network Settings > (Pick which network type your using) > Test Xbox Live Connection?

You should have three test objects, Network, Internet, and Xbox Live.  They should all show connected, below that will be the Xbox Live Status for Xbox Live Services, which can be disregarded.

Next, what results do you get when you go to Network Statistics?

Mine are - 
Network: Connected
Internet: Connected
Latency: 611ms
Packet Loss: 62%...
Upload Speed: 8.28Mbps
Download Speed: 44.04Mbps

Have you tried disabling/enabling Web-Acceleration to see if that makes any difference?
Go to!/wac/control then click on the green box, "Web Acceleration Enabled", it should change to orange.  After a few minutes try to connect again.

New Member

Re: Can't connect Xbox 360 to HT2000W

I am having the same problem as the first post. I cannot connect to Xbox Live. I called xbox and went thru some steps and they determined that it was a port fowarding issue. I called and was on hold 1hr and they said that they could help me with the problem. They asked me for the ports and told me to hold on and then they hung up on me. I called xbox and told them what happened and they told me that they cannot help people with port fowarding they are not allowed too. So I am going to try what you said. I went ahead and tryed my asumptions of what to do and it still didnt work. You can go to and click advan settings, NAT and click port mapping/triggering and I filled in the info and it didnt work. Please help me if you can.



Associate Professor

Re: Can't connect Xbox 360 to HT2000W

Can't really forward ports with the HT2000w on Hughesnet since we don't sit behind a public facing IP...

When you do the xbox tests that I stated above, what do you get...?

You are getting MTU errors, correct @hunterhancock41?

The more and more I look at this, it may be related to an already known issue, but I am unsure... Are you able to visit the xbox live website and log in there?

Re: Can't connect Xbox 360 to HT2000W

@C0RR0SIVE, I've tried the wireless and direct connect method from the xbox to the router/modem. I have no third party routers. 

When I select "Test XBox Live Connection", the results are: Network: Connected, Internet: Failed, Xbox Live: Blocked.


As for Network Statistics, they show...

Network: Connected

Internet: Failed

Latency: Blocked

Packet Loss: Blocked

Upload Speed: Blocked

Download speed: Blocked

Signal Strength: 100%

Wi-Fi speed: 12 Mbps


I tried the Web-Acceleration enabling/disabling option this morning with no luck. Any other ideas?

Associate Professor

Re: Can't connect Xbox 360 to HT2000W

I have no ideas...  I don't see why it's being blocked, this will probably require engineering to look into it... @Liz got any ideas or care to poke an engineer for some insight?

@Craigmcdonald22 and @hunterhancock41 can you guys try resetting the Network Interfaces on your xboxs?
Settings > System > Network Settings > Select the Network Type you are using (Wired or Wireless) > Configure Network > Additional Settings > Restore to Factory Defaults

Aside from that, I think this is going to require someone with more back-end knowledge to look into, it could be a gateway issue of some kind.

OK.... Now I am getting the same issue as you guys... Was working fine last night... Now it's failing tests.  Certainly not an MTU Settings issue though.

Re: Can't connect Xbox 360 to HT2000W


I've reset the xbox to it's factory defaults multiple times. really baffling. any other suggestions?

Associate Professor

Re: Can't connect Xbox 360 to HT2000W

Sadly, I am out of ideas, having hopes that @Liz can look into this tomorrow at some point.

I couldn't connect most of the day today, and now I can... Seems like a backend issue, possibly related to the Access Denied errors that people had been getting, though I think that was fixed.


Re: Can't connect Xbox 360 to HT2000W

Good morning everyone,


Welcome and thanks for posting details and working with C0RR0SIVE. I'll run diagnostics to make sure your systems are working normally and send over the information you've gathered so far to our engineers.


Can you also please let me know the exact error message you're getting? Is it always the same message?


When exactly does the error message pop up? (E.g. Immediately after connecting the Xbox to the network, after sign in, etc?)


I'll post back with any other questions and other news from the engineers as I get them. Your cooperation, patience, and understanding are much appreciated.






If you have a tech or billing question and need help, please start a new thread in the appropriate board. Unsolicited Private Messages may not get replies.

Re: Can't connect Xbox 360 to HT2000W

@Liz, After I select my network, I run the "Test Xbox Live Connection" test. It connects to my  network just fine, but I always get the "MTU Error" message as it tries to connect from the Network to the Internet. If I reset my router/modem, it WILL connect to the Internet, but not Xbox Live. It only does it once though. If you run the test again after not touching anything, it goes back to the MTU error. Hope this is the information you were looking for.