HughesNet Community

Cant get modem to convey wifi to phones

Showing results for 
Search instead for 
Did you mean: 
New Poster

Cant get modem to convey wifi to phones

I upgraded to gen 5 two+ weeks ago and have chatted with tech support over and over. The wifi keeps connecting and disconnecting over and over. It is very annoying when I try to order things online and the internet drops and I have to start again. I seldom use my computer. The techs say they can fix the problem from there, but nothing ever happens. I read somewhere that you can connect a router to the modem and then your phones will have wi fi. Before I do that, I want to know if that actually works. My main phone is a galaxy note 20 smartphone.  The other phone is just used for games. I cant transfer to the note 20 because the internet wont stay on long enough for me to change devices. I am not tech savvy at all. 


There was a bug in the early 2000W models regarding a problem with th 5GHz wifi constantly resetting. It's possible your modem hasn't been properly updated with newer firmware. Usually unplugging it from the AC power, waiting a minute or two, then plugging it back can force a firmware update to start.


However, there's a simpler, less elegant way around it: Use the 2.4GHz wifi instead. The 2.4GHz wifi is a lot stabler and goes a further distance than the 5GHz, although the tradeoff is slightly slower speed. It only has older 802.11b, g, and n protocols. The 5GHz wifi has faster 802.11a, n, and ac protocols which spread over twice the radio bandwidth.

* Disclaimer: I am a HughesNet customer and not a HughesNet employee. All of my comments are my own and do not necessarily represent HughesNet in any way.
Distinguished Professor IV



You can use a 3rd party router with the HT2000W modem.  If you do, make sure to disable the WiFi in the HT2000W so that the two sources (HT2000W and 3rd party router) don't interfere with each other.  To disable the WiFi in the HT2000W, see the following, which is a copy/paste from a previous post...


"Sign into the WiFi settings page of the HT2000W modem here, using admin as the password.  Then, on that main page, uncheck both the SSID Enable and SSID Broadcast boxes for the 2.4GHz band, then click Save Settings.  Then do the same for each of the other three, making sure to click Save Settings before moving to the next one (2.4 Guest, then 5, then 5 Guest).  If you do all four, then click Save Settings, the settings won't hold, so you have to do each of the four individually.


After all four have both SSID boxes unchecked, go to Advanced Setup >> Wireless (on the left), then uncheck both the "2.4GHz frequency band" and "5GHz frequency band" boxes, then click Save Settings.  Once this is done, you should see the modem's WiFi light go off, as the WiFi will then be completely disabled."


With this said, the reps here may want to troubleshoot your system to see if the problem actually lies with the WiFi itself, and if so, why.  They're on Monday through Friday from approximately 9AM to 6PM EST.

Ryzen 5 3400G | MSI B450M Pro-M2 MAX | 16GB Corsair Vengeance DDR4 3000 | XPG SX8200 Pro 512GB NVMe | Windows 10 Pro



Thank you for reaching out, and welcome to the Community! Before we proceed, I'll need a bit more information. Please send you account number or a phone number attached to the account to this link! This will help us take a look into your modem and figure out what might be going on.




Welcome to the HughesNet Community!

The HughesNet Community is here for you
to find answers and ask fellow HughesNet
subscribers for help. This is a great
opportunity to discuss and share your
expertise to enhance your HughesNet
experience and that of fellow subscribers.

Visit the About the Community board for
information on how to get started with using
this resource.