HughesNet Community

DNS errors in Gen5

Showing results for 
Search instead for 
Did you mean: 

DNS errors in Gen5

So Monday I got Gen5 installed but having issues.  Two devices connect to the WiFi but one device does not.  When I go to that device and type in my WiFi password it tells me it cannot connect.  The other issue I have is that I get frequent DNS errors.  The annoying part is I can open Facebook but not the games I use on Facebook, I can go to my yahoo email, surf the web.  I CANNOT get on though to try and solve my issue on my home computer because it gives me DNS problem.  

So I call Hughesnet and after a long conversation with someone that I don't think understood the problem, tells me I have a connection error and will send a technician out (at no cost of course).  Is there something I can do myself to fix this as I truly do not believe its the modem.  I tried Google Chrome, Firefox and Explorer and get the DNS message on all four????






Hi Tina,


We're really sorry to hear you are having trouble, especially since you just got our service. We know that is not a good first impression of our Gen5 service. I'll take a look at your system and see if there is anything I can find and fix on our end to resolve your issues with the DNS and connectivity errors. The device that cannot connect to wi-fi, can you tell me if you are trying to connect to the SSID starting with hug2g or hug5g?


Thank you,


I believe it's hug2 but can't be sure until I get home and check.  Then I'll have to log on using my cell because I cannot open this website on my desk top lol.


Oh my gosh I got the filimin to connect to WiFi!!!  One issue solved now for the DNS issues and the faulty connection (which I believe is the black DC in cord).  It is not flush with the modem and I cannot push it all the way in!!!  Hopefully when the technician comes tomorrow he replaces is and my other issue will go away!!!

Distinguished Professor IV

If I start getting DNS errors what I do that usually helps is to flush my DNS cache.  I get them occasionally when trying to go to Amazon.    


If your computer is Windows based, open a command prompt and type "ipconfig /flushdns", without the quotes, then hit Enter.  It should give you a message that the flush succeeded.  Then close the command prompt and try the webpage again.  

Ryzen 5 3400G | MSI B450M Pro-M2 MAX | 16GB Corsair Vengeance DDR4 3000 | XPG SX8200 Pro 512GB NVMe | Windows 10 Pro

Thanks I'll give it a try!!!