Hughesnet Community

Gen5 ftp broken since 15 December 2018

Showing results for 
Search instead for 
Did you mean: 

Gen5 ftp broken since 15 December 2018

Since 15 December 2018 ftp access to my web server has stopped working reliably day and night. Sometimes I can get a reliable fast connection, other times a connection but very slow, and many times no connection at all.  I tried a friend's ftp server that uses a different host in a different part of the country and still have the ftp problem.  I searched the Forum and see that over the years many users have had ftp problems with HughesNet.  http access to the server works fine.  I have rebooted the HN modem and one of the computers used to access ftp but that didn't help. I see this problem on multiple Macs and multiple iOS devices so it would appear that the common source of the problem is HughesNet.  Why?  What's the fix to get reliable HN ftp again?


Could be latency.  BUT I never had this problem until 15 December 2018.  I've been on HughesNet since 2013 and Gen5 since 2017.  And I still see about 700ms pings, which has been consistent since 2013.




Could you please send me the FTP URL? I would like to escalate your issue to the engineers.


Thank you,



Thanks.  The URL is  


I'm not ready to declare ftp success yet but yesterday morning, last night, and this morning ftp worked fine.  That's the longest period of time since this problem started on 15 December 2018 without ftp connection issues.  (And no, the Mac and iOS updates that Apple released on Tuesday do not factor in.  I have not yet done any of those updates.)

Distinguished Professor IV



I like your site.  You've done some very impressive and exciting things in your life thus far.  🙂 

Ryzen 5 3400G | MSI B450M Pro-M2 MAX | 16GB Corsair Vengeance DDR4 3000 | XPG SX8200 Pro 512GB NVMe | Windows 10 Pro

Thanks!  I've had fun over the many years.


As to the ftp issue, still can't declare success.  Didn't work Wednesday night.  Two hours later still didn't work.  Two minutes after that it did work.  Worked this morning too.  So still hit and miss.

ftp problems via HughesNet continue hit and miss.  Saturday night (MST) could not connect to my ftp server through HughesNet, but could using the AT&T cell network.  Sunday morning (MST) an ftp connection was made but then it dropped.  I reconnected and managed to get the small HTML and JPEG files uploaded.  I'm on the top tier service for residential.  So whatever problem that started on 15 December 2018 is continuing.

ftp connections are still hit and miss.  Supposedly HughesNet was going to try an alternate beam but I never received a confirmation of that.



I am still working closely with engineering on this issue and will reply back as soon as I have any update!  Your patience and understanding are much appreciated.



Here's more information on this failed ftp situation with HughesNet.

As has been the case since December of last year, ftp connections continue to be hit and miss from multiple computers and handheld devices.  Many times the initial connection to the ftp server will fail, only to work a few minutes or hours later. Other times the connection will work, only to fail a few minutes later. It has even failed in the middle of uploading a small TEXT or JPEG file (10-200 KB) to the ftp server.

To make matters even worse, other connections are becoming unreliable.  I am seeing increasing random failures getting email (IMAP), web pages (HTTP), and even software updates (OS, applications).

The frustrations continue to build...





Engineering has been working on this issue but have yet to see the FTP fail. I am still working with them to resolve this issue for you and I will be sure to provide them with this most recent feedback.


Your patience and understanding are much appreciated.



Thank you.

Unfortunately there has been no obvious pattern to the hits and misses.  Most of my ftp connection attempts occur 0730-0750 MST and 1800-2100 MST.  I see successes and failures during these times as well as at other times during the day and night.  It just seems so odd that these issues started in December 2018 with no additions or deletions in the devices connected to my local network.



Our engineers have been unable to reproduce the issue fully as they continually get the login prompt.

They recommend trying different types of FTP (Passive or Active) and trying other FTP applications to see if you consistently receive the same results. 



Thank you for the update.  It is still hit-n-miss with multiple apps, multiple computers, multiple handheld devices, and with and without passive enabled.  I've tried all that since the problem first started in December 2018.  Prior to December 2018 there were NO ftp access issues.  The only way I can get consistent ftp access is via the AT&T LTE network on my handheld devices.  I do continue to see what looks like worsening IMAP and http download speeds.  Sometimes the various speed test sites and iOS apps fail to even start due to horrendous (0 Mbps) download speeds.  Perhaps the HughesNet system has overreached its user capacity.

A thought has occurred to me about a possible cause for the deterioration of my HughesNet service.  When the technician came in January 2019  to troubleshoot the ftp issue he said he saw high error rates.  He replaced the modem and the dish electronics.  Of course, that hasn't solved the issue.  What was not replaced was the coax cable run from the dish to the modem.  About 40 feet of that cable has been exposed to the harsh weather here (Sun, hail) and possibly birds pecking at it since the system was installed in 2013.  The cable just lays on the Sun-facing side of the roof and runs down the east side of the house.  It was not installed in a conduit to protect it.  If the cable shield has been damaged (hail, birds) perhaps that could be the cause of all the ftp, http, https, and imap issues I've been seeing.  Comments anyone?

I still think it's CenturyLink.


Edit: Anyway, I would tend to think a cable failure such as this, would not be as intermittent unless it was flapping around in the wind.

* Disclaimer: I am a HughesNet customer and not a HughesNet employee. All of my comments are my own and do not necessarily represent HughesNet in any way.
Assistant Professor

@MarkJFine wrote:

I still think it's CenturyLink.


Edit: Anyway, I would tend to think a cable failure such as this, would not be as intermittent unless it was flapping around in the wind.

Have seen intermittent problems with coax when water invasion is the issue. Failure when wet, dries out and works fine till next time it rains or gets wet from melting snow, etc.

True, but I've had the same extrernal cable run since I had a 7000 modem. Only difference is now they're using one cable instead of two.

* Disclaimer: I am a HughesNet customer and not a HughesNet employee. All of my comments are my own and do not necessarily represent HughesNet in any way.

Ah, CenturyLink.  We had their DSL.  But after a few years their service deteriorated too.  It got to the point that about once a month I had to call them about the download speed dropping to 0.3 Mbps (from its normal of 1.2 Mbps).  Their solution was to reboot a server on their end.  That solved the problem for about 30 days, then I had to call them again and they had to reboot their server again.  After a few months I got tired of dealing with the hassle and switched to HughesNet.  That was in 2013.  All was well until December 2018.  Now it seems that HughesNet might be suffering from the same type of service deterioration (for whatever reason).  Perhaps the solution needs to be the same: reboot some server on their end every month.  Worked for CenturyLink.  Worked for me until I got tired of it.

Friday, 15 March 2019, at 0720 MST, ftp was totally dead.  I rebooted the modem 0723 MST.  But when the modem came back online it had lots of errors, mostly related to Web Acceleration (which had been ON before the reboot).  The Internet connection (all protocols) was dead.  I reset the Web Acceleration MBX but that didn't help; still no Internet connection at all.  I then disabled Web Acceleration.  The Internet connection returned.  AND ftp worked this time.  I assume that rebooting the modem is not supposed to kill Internet connectivity.  Perhaps this morning's episode is another clue in the long list of clues about why my HughesNet connection is so flakey.  Replacing the modem in January didn't help.  Disabling web acceleration in the past didn't help with the ftp connections, so I doubt it has any bearing on why ftp worked after disabling it following this morning's flawed reboot.  And so the saga continues...

Per a private message from Jay, I called HughesNet this morning.
I had to re-explain the issue to the Customer Service rep even though she could see the referenced case# that Jay gave me with instructions for me to talk to the Home Technical Support team. That seemed to be a waste of my and her time. Since I was directed to call HN and use the case# to be connected to the Home Technical Support Team, she should have immediately connected me to that department. It took 10 minutes before she connected me to that department.
Once I got to Brett at Home Technical Support I had to re-explain the issues.  Unfortunately he could not do much since it wasn't his job (he is a contractor for HughesNet).  However, he did have me do some things that no one else at HughesNet had ever suggested.  He had me change the modem/router DNS settings, the Wi-Fi bandwidth, and update the time settings. Now to see if these changes solved the issues I've been experiencing since 15 December 2018.  Stay tuned...

Understand the DNS and bandwidth issues.


Resetting the DNS because of a bad entry is always a good first thing to do. However, I'm not sure setting it to something other than the default (Obtain from ISP) is a good idea. Third-party, free DNSes might be quicker than HN's, but are exremely susceptible to spoofing.


Using 802.11ac (40 channel, 80MHz b/w) on 5GHz should be done whenever possible, because it allows the maximum transfer rate. Some older devices don't do 'ac', just 'n' or 'g'  so you might not get the full b/w or it might not work at all (no 'g' on that setting).


Setting the time zone is curious advice, since I'm not certain anything other than the internal logs themselves do anything with it. So, that's just weird.

* Disclaimer: I am a HughesNet customer and not a HughesNet employee. All of my comments are my own and do not necessarily represent HughesNet in any way.