Hughesnet Community

Gen5 upgrade

Showing results for 
Search instead for 
Did you mean: 

Gen5 upgrade

I upgrade from Gen4 to Gen5 yesterday and can't get some websites to load. It is almost random as to which ones but in trying to do research using Google (Safari) its a pain trying jump from website to website to find material I'm looking for since I wait for the site to load and it just sits. Didn't do this with the Gen4. Whats the difference in settings? It appears from the speed tests that it isn't the speed but compatibility between Gen5 and some sites. Any ideas? By the way, one of those sites is the US Postal Service. Can't get it to load for anything...


After 15 minutes the USPS site loaded. Clicking any links on the site gets the same 15-20 minute response?


I rebooted everything, modem, router, and computer. It appears to be something with any links. If I do a search and get a results list it takes a number of minutes to load any link thats clicked.



If it is just a few websites that don't work this could be server related for the websites. The best I can recommend for that is to just make sure that the device is directly connected via Ethernet or you have excellent WIFI signal. Not sure if the initializing stage is causing this issue as well but it is worth a try. -Damian 

Distinguished Professor IV



Though you did state that you rebooted everything, just in case it could be a DNS cache issue, I suggest shutting everything down at the same time, and this means any devices that connect to the system. With the HughesNet modem itself actually unplug it so that no power is going to it whatsoever. Then, after waiting at least a minute or two...


- plug the modem back in, then wait at least three minutes to be sure the modem is all the way back up and fully ready

- then boot the router, and again, wait a couple of minutes after doing so to ensure it's fully back up and ready

- then boot your computer and see if there is any difference


The idea with this is to clear the cache from not only the modem and router, but from all devices.


HOWEVER, I would wait until tomorrow before trying this. I wouldn't want unplugging the modem interfere with any initializing the system may be going through. I don't know that it would actually do that, but I just mean it's probably best not to take the chance. I don't know whether it's a DNS related thing, but if the system is changed and the old DNS addresses are cached, it could result in weird things when trying to browse and open pages.


Whatever the case, I hope it's ultimately resolved for you, one way or another.

Ryzen 5 3400G | MSI B450M Pro-M2 MAX | 16GB Corsair Vengeance DDR4 3000 | XPG SX8200 Pro 512GB NVMe | Windows 10 Pro



Thank you for reaching out to us and I am sorry to hear this. Since you just recently upgraded to a new system, it takes a bit of time to initialize and perform as designed. Usually this waiting period is 24 hours but can be longer in rare cases. If you find that the service is still underperforming tomorrow, performing a power cycle is recommended. This is just unplugging the modem from the wall outlet for 30 seconds and plugging it back in. Power must me drained for the reset to be effective. Please update me on how the equipment is performing after that. -Damian  


If its still giving me problems tomorrow  I'll repost.



Something to be aware about:

There are severe weather issues in the middle of the country, where a lot of internet hubs are. If those areas have rotating power outages due to the weather (like in Texas, where the power grid is a complete disaster), the internet will attempt to dynamically re-route itself around those areas. More often then than not, this causes havoc as those DNS tables may take more time to re-propagate than the outages occur, so it's in a constant state of flux.


Just throwing this out there.

* Disclaimer: I am a HughesNet customer and not a HughesNet employee. All of my comments are my own and do not necessarily represent HughesNet in any way.
Distinguished Professor IV

In short, "weather bad; many problems." 


Fixed it! Removed the Apple router and started using the modem router. Everything works now.

Distinguished Professor IV

If you'd mentioned the Apple router in your OP, we would've told you to chuck it.  🤣