HughesNet Community

Invalid OpenID or Credentials.

Showing results for 
Search instead for 
Did you mean: 
New Member

Invalid OpenID or Credentials.

I am attempting to determine my current plan so I can either stop service or continue and upgrade with Hughes net. Is there a solution? 


Distinguished Professor IV



Being that you can't sign in....


What modem do you have?  







A monthly data plan, or daily?  How much Anytime Data, or if a daily plan, overall data, do you get when it is reset?  If your Usage Meter is working properly, you should also be able to see how much Anytime Data you normally get from there.   


When did you sign up for service?  Have you upgraded recently?  


Edit:  I don't know if the following post will help with the Invalid OpenID or Credentials issue you are experiencing, but it may.....


Ryzen 5 3400G | MSI B450M Pro-M2 MAX | 16GB Corsair Vengeance DDR4 3000 | XPG SX8200 Pro 512GB NVMe | Windows 10 Pro

Good Morning tjlaband,

Welcome to the Community and thanks for posting. You are currently a Gen4 customer on the Power Pro plan. What are you trying to access that is giving the Invalid OpenID or Credentials error? Thanks.


I have had an ongoing issue with open invalid id and credentials myself ever since I was upgraded to gen 5. I wanted to share with every one that yes its unfortunate seeming like a Beta roll out without things working the way they should. However this is what I have found out and experienced and wanted to share with community.

Its apparent this is a very large issue after reading dozens of posts similar to my problem. After hours on the phone the only way this open id and credential thing was solved is when the operator created a DUMMY Account and I logged in to that. She gave me the option to keep the dummy account but I was uncomfortable with that.  I am still unable to see my account information, unable to download a usable status meter, and the router in my new modem is not working correctly. Can I share an i.p address anyone can put in their address bar to see and adjust their router in the new gen 5 modems.  And see your up to date data usage. It is

To this end it is frustrating, because every piece of hardware needs software to function and the software that controls the new modems with the routers in them is located at the Hughes website with the address I just gave of even though I have turned off the router through it’s software, it is still broadcasting a signal in both 2.4 and 5.4 in both the guest lines too.which means my Hardware is still turned on, i.e. The router is still broadcasting a signal and our laptops are trying to log on to a phantom signal that the router is putting out. Multiple problems that should have been ironed out before the roll out of gen 5.

My discontent is in that Hughesnet will not replace my new modem which cost 350. Dollars and is brand new and not working the way it is designed to. Other than that I tried everything you could imagine with the help of the operators over hours of conversation and still have the same three problems.

1 no way to see my account information

2 no usable status meter or way to use a token

3 the router although turned off at hughes end is still broadcasting a signal.   Thanks for your time  ThomasJ


Distinguished Professor IV



First, the address is for the modem's System Control Center.  It's local.  It's not a Hughenset website.  Some of the info you can see in the System Control Center is from Hughesnet's servers, but that IP address is local to the modem.  



Secondly, there are two ways in which to turn of the radios in the modem/router.  


The first method actually only turns off the broadcast, but does not turn off the physical radios.  


You MUST UNCHECK EACH OF THE TWO BOXES (Enable and Broadcast) FOR EACH RADIO, THEN CLICK SAVE BEFORE GOING ON TO THE NEXT.  So, uncheck the SSID Enable and SSID Broadcast boxes for the 2.4Ghz radio, then click SAVE SETTINGS, then uncheck the same for the 2.4Ghz Guest radio, then SAVE SETTINGS, then the same for 5Ghz, then SAVE SETTINGS, then 5Ghz Guest, then SAVE SETTINGS.  Doing all of them at the same time, then clicking Save Settings, won't work.  I don't know why, but it won't.  You have to do each one separately. 




The second method actually turns off the radios, or at least acts as if it does, as it turns off all broadcasts of any kind.  


Uncheck the box for each Frequency Band, then click SAVE SETTINGS.  With this one you can click both at the same time and then click SAVE SETTINGS.





Lastly, though you've seen a number of posts regarding this, the Invalid OpenID or Credentials issue is actually only affecting a small number of individuals.  Still, I hope they are able to solve your issue with such.  


Also, are you using Windows?  The Hughesnet Usage Meter should be working.  With that said, I don't know if the Invalid OpenID or Credentials problem also affects the Usage Meter.  


Ryzen 5 3400G | MSI B450M Pro-M2 MAX | 16GB Corsair Vengeance DDR4 3000 | XPG SX8200 Pro 512GB NVMe | Windows 10 Pro