HughesNet Community

No Internet - security certificates

Showing results for 
Search instead for 
Did you mean: 
New Poster

No Internet - security certificates

I have tried leaving modem unplugged and plugging back in, but continually get security warnings to every website I try to visit and am unable to ignore them. I have been without internet for about a week and am having this problem with all of my devices. Any ideas?
Distinguished Professor IV

What do the warnings say?  Could you post a screenshot?

It will not allow me to post a screenshot but here is what they say

On safari it says “ this connection is not private. This website may be impersonating “” to steal your personal or financial information. You should go back to the previous page”
On Firefox it says “did not connect: potential security issue. Firefox detected a potential security threat and did not continue to because this website requires a secure connection. “
On my iphone it says “safari cannot open this page because it could not establish a secure connection”
Distinguished Professor IV

The Hughesnet people won't be here until tomorrow, but I'm tagging a couple of very knowledgeable users who may be able to help you figure out what's going on. 

@MarkJFine , @GabeU 

If you're having problems going to multiple sites securely, chances are you have either a corrupted DNS somewhere (hopefully), or some malware is re-routing you to some naughty sites.


You can fix the DNS problem by doing the following, in this in this order:

1. Power down as many devices as possible using the internet. This includes computers, phones, tablets, satellite TV boxes, etc.

2. Then power down the modem by unplugging the power cord from the wall.

3. Wait a minute, then plug the modem back in.

4. Wait until the modem is fully running and all lights are lit on the front panel, then re-apply power to the devices that were running previously, one-by-one.


If that doesn't fix it it's likely a malware problem, and that can be so complex and from so many sources that I have no idea how to help you.


* Disclaimer: I am a HughesNet customer and not a HughesNet employee. All of my comments are my own and do not necessarily represent HughesNet in any way.
Distinguished Professor IV



From the sounds of it, it's likely either a certificate issue on HughesNet's end, or something going goofy with the modem.  The only thing I could suggest is power cycling the modem, but it sounds like you've already done so.  If it were only happening on one device that'd be one thing, but with it happening on all it's got to be something having to do with HughesNet. 


I'm also assuming that you're only using HughesNet's own equipment and that you don't have a 3rd party router in the mix.  


Though I don't think it would have anything to do with DNS entries, one thing you can try is the following...


1.  Shut down all of your devices.  Actually shut them down, don't just put them into sleep, hibernate or other standby.  

2.  Unplug the HughesNet modem from the wall outlet or power brick (NOT at the back of the modem).  

3.  After at least a minute, plug the HughesNet modem back in.

4.  After at least five minutes, start only your computer, and if would be best if this computer were connected via LAN cable rather than WiFi.  Then, once the computer's up, try to go onto a website.  If it works, then turn on the next device and try the same.  If it works, then do the same with each of the rest of your devices, but one at a time.  


If this doesn't work, you'll very likely need to wait to see what the HughesNet reps have to say, as it may very well be a problem that they need to attend to.  They're on M-F from approximately 8AM to 5PM EST.  They usually reply within a working day.  


Edit:  Mark replied while I was typing.  Sorry for the redundancy with some of my reply in comparison to his.

Ryzen 5 3400G | MSI B450M Pro-M2 MAX | 16GB Corsair Vengeance DDR4 3000 | XPG SX8200 Pro 512GB NVMe | Windows 10 Pro

I am using all Hughesnet equipment, no third party router, and still no luck after following the steps.

Hello Claire,

  Welcome to the community and thank you for posting. I would recommend calling into 866 347 3292 for real-time support, and they should be able to get you over to our Home Tech Support. They have the ability to remote in and look further into your devices to locate the issue at hand.




It's been a while since we last heard from you, so we will close this thread. If you still have concerns, please start a new thread and include a detailed explanation so we can better assist you.


Welcome to the HughesNet Community!

The HughesNet Community is here for you
to find answers and ask fellow HughesNet
subscribers for help. This is a great
opportunity to discuss and share your
expertise to enhance your HughesNet
experience and that of fellow subscribers.

Visit the About the Community board for
information on how to get started with using
this resource.