Hughesnet Community

Unable to access URL with port :2087

Showing results for 
Search instead for 
Did you mean: 

Unable to access URL with port :2087

I'm trying to access the control panel for a web server (ie when there is a port in the URL. Haven't had issues with this on other networks. But I'm on Hughesnet Gen5 Business with a static IP and unable to access this URL. Says the site cannot be reached. 


Is there something blocking :2087?  I've disabled the local firewall, then also enabled, tried to open ports, etc, rebooted, nothing has worked.


Is it possible to open that port or another fix to get to that type of URL?






Distinguished Professor IV



You may very well have better luck contacting HughesNet Business Support at 800-347-3272.  


Though another customer who sees this may have some ideas, being that this community is primarily for residential subscribers it's likely that the HughesNet Reps themselves who provide support here will not be able to help.  You never know though.  Still, the support at that number may be better equipped to help with the issue.  


Good luck.  🙂

Ryzen 5 3400G | MSI B450M Pro-M2 MAX | 16GB Corsair Vengeance DDR4 3000 | XPG SX8200 Pro 512GB NVMe | Windows 10 Pro

I think the only port they block is 25 for email security purposes, so it's not a port problem.

Whenever I run into something like this I almost automatically assume it's a corrupted DNS that's causing the problem. Try rebooting the modem and see if it unclogs it.

* Disclaimer: I am a HughesNet customer and not a HughesNet employee. All of my comments are my own and do not necessarily represent HughesNet in any way.

Tech support was saying if it's a port issue, I will have to do some port forwarding/port mapping.


In this case, port 2087.  Although he wouldn't tell me over the phone - they require a $79 fee or something and they'll set it up over remote desktop. Frustrating.


I'm in the port mapping on the router, and I know  my local IP and know the port, but then it wants a LAN Port. I've tried setting that to 2087, I also tried some other ports found on netstat like 135, 445, etc but not sure how to identify my LAN port.


Attaching screenshot if anyone has a clue or has done this before:



No clue how or even if port mapping actually works on that modem. It doesn't for residential customers. Sorry.

* Disclaimer: I am a HughesNet customer and not a HughesNet employee. All of my comments are my own and do not necessarily represent HughesNet in any way.

I don't think that's right.  Port forwarding/mapping is generally for incoming traffic, but you are trying to go outbound to a webserver listing on port 2087.  If you were going to host a webserver listening on port 2087 you'd do these steps, but it doesn't sound like that's what you are doing.


You said you disabled the "local" firewall, what do you mean by local?  The one on your computer, the one on the router, something else?  Have you tried connecting to that address on a different device?



I thought the same thing. The tech said port mapping. I feel like Ive done this before like with xbox or gaming servers like back in the day, had to open up ports on a router, but can't recall how.


But yeah this seems like if I were hosting a web server or something. But I'm just trying to ACCESS a server using a specific port. Just like FTP or other services you usually have to open up. 


Very strange. Other devices can't reach the server. But when I leave the house and on normal verizon I can reach server just fine.  So it's something with hughesnet and that port. 



For the firewall, there's a firewall section in the router admin that was enabled. I tried disabling and that did nothing. The tech said the firewall is just to protect people from accessing my equipment, etc. Shouldn't have to do with outgoing.

Who knows, I may just have to pay the fee and watch them do something very simple to get this to work.

Did you try rebooting the modem to clear the cached DNS like I said?

* Disclaimer: I am a HughesNet customer and not a HughesNet employee. All of my comments are my own and do not necessarily represent HughesNet in any way.

Yes, rebooted several times. Also unplugged, plugged to fully reset. no luck.  I'll keep messing with settings, it's something with that 2087 port.


Also, I got the biz package with static IP so I could VPN into a client (that opens up your IP addy for access) and that doesn't work. Tech said the latency is too high for most VPN systems to work properly. Ugh!

Is this a new website/domain you are trying to reach?  Either way, it could be a DNS issue, but one that is specific to Hughes and not just your router.(it's just more likely to be the case if the website is new, because it can take time to propogate the new DNS entries across the internet).  You can try changing the DNS in your router to not use the Hughes DNS and instead use something like Open DNS.  The addresses you can enter are:  and  You'll likely have to flush your DNS on your local machine and clear your browser cache too after you make that change.  If you lose internet connectivity, be ready to switch that back.


For VPN, actually you probably would need to setup Port Mappings to VPN into your network.  Your VPN server software will be listening on some port and your Router would have your "public" static IP address, but that address represents your entire network as each computer inside your network has only private addresses.  So your "remote" client will hit your router on a specific port, but the router needs to know to forward that to your VPN server, and that's where the Port Mappings come in.


It would be setup like the following

1. LAN IP Address: Is the IP address of the machine running the VPN server software (you can make that always be the same thing via the LAN DHCP page where you can make the router always give it the same address)

2. Protocol Type: This is probably best to setup for both TCP and UDP, though your VPN software documentation might have the specifics

3. Public Port: This is the port that your remote client uses to try to reach your VPN server.

4. LAN Port: This is the port that your VPN Server software (which is running at the IP address specified for #1) is lisenting on.


Often 3 and 4 are the same value, but they don't have to be.


Now I don't know if HughesNet is performant enough for the connection to stick, but that should at least allow your traffic to flow from your remote client to your VPN Server.  However, if your router is somehow blocking sending on non standard ports (like 2807) you may have to configure your VPN software to use common ports like 80 or 443 in order for your router to not block the traffic your VPN Server is sending back, until that is figured out.

Thanks @Michael57 


It's not a new site and works just fine if I'm out on my mobile network, or at a hotel, other location with this laptop. So it seems to be related to hughesnet and that 2087 port.


For the VPN, that also works fine on this laptop from my previous location where the client added my IP address to the network for access. But now moving here and switching to Hughesnet business, and getting a static IP, I had the client add this new IP address but I'm still unable to acces the site. Works fine on this laptop at the previous location. So the only difference is hughesnet.


The tech explaining how the the latency can cause issues for VPN makes sense. But I wish I had known that before I switched from residential to business for an added expense just to get an assigned public IP. It isn't faster than residential that I can tell. so there was no need to switch if I'm unable to VPN to a client.


Appreciate your help. I wish I could at least get the port 2087 figured out - it's a control panel for a web server I need to access now and then. 



@JamesGen5Biz wrote:

It's not a new site and works just fine if I'm out on my mobile network, or at a hotel, other location with this laptop. So it seems to be related to hughesnet and that 2087 port.



Yes, that's why I suggested changing the router to use a different DNS server instead of the Hughes DNS server.  If you can access the website without the port number, then it's probably not a DNS issue but if not, I would definitely try changing out those DNS settings.


I misunderstood your VPN use case, I thought you were trying to VPN into your local network.  I do use VPN from the hughes network.  It's very slow, even slower than normal traffic because VPN traffic is probably deprioritized, but it is stable.  My VPN client uses port 443, If your VPN client is going outbound on a port other than 80 or 443, it's probably having the same issue as trying to reach your webserver control panel, it's being blocked for some reason.

Part of the issue with slowness on VPN is that is required to bypass all acceleration techniques for security purposes. Same with ssh. Then there's the whole extra ack/nack and encryption thing in that unaccelerated channel. Not fun.


I'm retired now, but when I worked at home I needed to use VPN in order to get to an Outlook enterprise server for email. Those are days that I'm glad are way past me.

* Disclaimer: I am a HughesNet customer and not a HughesNet employee. All of my comments are my own and do not necessarily represent HughesNet in any way.

Yes, VPN is always going to be slightly slower (though compression at the end points will make up for the most material parts of acceleration) with the extra hop in the routing, the encryption, and the chattiness going on.  However, it's going to be even slower on congested networks running running QoS or other prioritization techniques, otherwise users would get around that prioritization simply by using a VPN.  So, ISPs pretty much have to lump VPN traffic into the standard or lowest tier.  If the ISP isn't overly congested then that won't matter much, but if it's going to slow way down like what I see on Hughes. 

@Michael57    Yes, I can access the main domain withou the port number. It's just a cpanel landing page, so the domain itself is working. 


And I had the same thought on accessing my client's VPN. Is it running on another port that may also be blocked. There isn't a port number in the VPN url I access that worked from the other location. But could be some routing happening behind the scenes that is not getting through with Hughesnet. Seems like anything I try to do outside the normal web and email ports, don't want to work. Just can't figure out how to open them up on my end. Maybe they are blocked at hughesnet access level. 


Even if it was really slow, I could get by. I only need to access either of these sites now and then. That's what is so frustrating. I may have to rent an office in town just to get their high speed/fiber internet and will then have no issues accessing these sites. But that's another monthly fee that's unexpected. 





Looks like the other website I can't access when on Hughesnet, uses port 2660.


Has anyone been able to open up ports with their setup? I feel like it's all in the router but have tried everything from various port ranges (under NAT section of settings) as well as disabling the firewall, disabling windows firewall, etc.


How do i open up an outgoing port so I can access these remote servers? 





I was hoping to test that this weekend as I host a webserver on a different ISP listening on a non standard port.  I even specifically opened up port 2087 so I can test the exact same port.  Unfortunately, I'm not on Hughes at my primary residence and was not able to make it to my Hughes based location over the holiday to test.  Maybe this weekend...


Anyhow, while it is possible that this is a router level setting, it may not be.  For instance, Hughes blocks port 25 and that's done across their network, not at the router.  Generally routers would not, by default, block traffic like that.  It isn't inherently unsafe to send http(s) over non standard ports, especially outbound.  So if it is at the router, it's a little non-standard, but definitely possible.  At the router, a Firewall config may block stuff like that, but you disabled the firewall so I'd expect that traffic to flow right out.


In doing some research about Hughes and ports, most links refer back to port mapping, which again probably isn't applicable to your case.  I did find an old post from Liz that stated Hughes only blocks port 25 and that post referenced another source.  Unfortunately, that was a very old post (like 2016 I think) and the link to the source post was broken.  It's possible things have changed.


In the meantime, you could try using an external proxy server or maybe try the TOR Browser (I think TOR uses an external proxy behind the scenes for you), though I'm not super familiar with it, but it's probably worth a shot.  

@Michael57  Really appreciate the insight and having another set of eyes on this. It's baffling.


I'm going to be in town tomorrow where I can test some things on my mobile hotspot to make sure I can still get to the cpanel login. I did see someone in the past having issues getting to their PLESK panel which is basically the same thing. 


If I run a tracert to that :2087 URL, it doesn't even try to find it, says unable to locate. If I do the domain without the :2087, it finds it just fine and runs through the hops to get there.


I tried the VPN URL that I also have trouble with, and a tracert it will get like half way there and die... so I think thats the VPN delay that I've seen mentioned where it just can't get there in time... it was many seconds to even get halfway there.


Well I'll see how tomorrow's test goes. Next step is I'm having to rent an office space to get fiber internet in town and I''ll be able to connect to all this stuff that way. But frustrating to not have that connectivity at home for sure.




I finally made it to my location where I'm on HughesNet.  I was able to connect to a website on port 2087 and a couple of other random ports I opened, so it's not being blocked across the HughesNet network.  Since you are blocked on multiple devices that work fine when not on your Hughes network, then I have to agree that it's likely in the router and not on the PC.  The only thing that I can think of that would cause it, is the firewall, but you've said you have disabled that.  The only other difference is that you are on a business plan and I'm on residential, I am not sure if that adds an additional security layer that could be getting in the way.


I am a little confused about your traceroute, you should at least see it hit your router before being stopped.  However, traceroute doesn't really use a port test like that, it's just sending ICMP packets so it's not really going to be a useful tool for this.  My guess is on Windows it doesn't allow you to specify a port (which makes sense) so  specifying a port in the URL is bad syntax which is why it doesn't go any further.  On a Mac you can specify a port with the -p option, but that's to get around port conflicts which shouldn't be an issue for you. 


My only suggestion at this point is calls to the Business Tech Support, sorry 😞 





It's been a while since we last heard from you, so we will close this thread. If you still have concerns, please start a new thread and include a detailed explanation so we can better assist you.