cancel
Showing results for 
Search instead for 
Did you mean: 

slow internet speeds even after plan upgrade

New Poster

slow internet speeds even after plan upgrade

I've been experiencing very slow internet speeds, even after
I upgraded to the 'Max' plan, with speeds up to 15Mbps.  Facebook/Youtube videos buffer for minutes and IOS updates on my cell phones need to be performed on my Verizon data plan.  When I run the Hughesnet speed test, it indicates that I am getting download speeds as high as 25,753 KBPS but TestMy.net speed tests performed within minutes with the 12MB file size indicate download speeds between 1.47 & 2.41 Mbps. These tests were run with the WiFi disconnected on all four cell devices in the late evening (10:00 pm) hours. I am running a HP desktop computer, hardwired to a Netgear R6400 wireless router from a Hughnet HT1000 modem.

Why such a difference in speed results and what can I do to improve performance since I am on the fastest plan offered in my area?

19 REPLIES 19
Distinguished Professor IV

Re: slow internet speeds even after plan upgrade

budkeil,

In order to address your speed issues, there are some tests that need to be run, even though you've already run a few.  They need to be done following a certain protocol.  

The following is a copy/paste from another post, but the process is the same, nonetheless.  You mentioned that you are hardwired to your Netgear router.  When running the tests, the router must be eliminated altogether, with just a single device connected directly to the modem with a LAN cable.  Also, and it says this twice below, but make sure you set up a testmy.net account and run the tests under that account....


Here's what you need to do to address your speed issues.

Create an account at http://testmy.net/.  While signed into that account, and using a single device connected directly to the modem with a LAN cable (NO ROUTER), perform a batch of three download tests using the manual 12MB test size, spacing each test five minutes apart.  If you can, run a batch of tests a few times throughout the day, preferably in the morning, afternoon and evening.  After you have run some tests, click on the Results tab, then copy the URL in the address bar of the Results page and paste it into a post on here.  It will look like the following, but with your testmy.net user name where it says [yourusername]. 

 http://testmy.net/quickstats/[yourusername]

Most important points...

Create an account at testmy.net
Run the tests while signed into that account
Run the tests with a single device connected directly to the Hughesnet Modem with a LAN cable (NO ROUTER)
Use the manual 12MB sized file for download tests
Space each test at least five minutes apart
Post your results here by posting the Results page URL, which will look similar to this... http://testmy.net/quickstats/[yourusername]

 

AMD FX-6100 | Samsung 250GB 840 EVO SSD | Western Digital Blue 500GB HDD | 16GB DDR3-1866 | EVGA Geforce GTX 550ti | Windows 10 Pro 64-bit
Moderator

Re: slow internet speeds even after plan upgrade

Hello budkeil,

Welcome to our community and thank you for your post. Looks like you have already gotten a jump start on the speed tests, so if you have the results page URL that GabeU refers to above, that would help us in investigating.

Just an FYI, I ran some diagnostics on your equipment and see that there may be a misconfiguration in your router which is could be a problem. At some point when you see this post, can you reboot your router and let me know when you did that? I would like to take a look at the logs when that occurs to get a better understanding of if it was a one time issue that is stuck or a reoccurring problem.

Thank you
Amanda
New Poster

Re: slow internet speeds even after plan upgrade

Amanda, I rebooted my router.  GabeU, the tests that you prescribed are underway.  I should have results tomorrow morning.
New Poster

Re: slow internet speeds even after plan upgrade

Amanda/GabeU, here are my results from the testing requested.  I also ran the Hughnet speed test before every TestMy.net test for a comparison. 

http://testmy.net/quickstats/budk

Distinguished Professor IV

Re: slow internet speeds even after plan upgrade

Ah, great speeds during the day, but not so in the evening.  

The Reps are on M-F from approximately 8AM to 5PM, so I'm sure Amanda will see these tomorrow.  
 

AMD FX-6100 | Samsung 250GB 840 EVO SSD | Western Digital Blue 500GB HDD | 16GB DDR3-1866 | EVGA Geforce GTX 550ti | Windows 10 Pro 64-bit

Re: slow internet speeds even after plan upgrade

Amanda, He says he has the HT1000 modem. Shouldn't that be upgraded?
New Poster

Re: slow internet speeds even after plan upgrade

Amanda, I also have a Asus RT-AC66U wireless router that I can use in place of the Netgear R6400.  I though I was upgrading when I went to the R6400 but that may not be the case.
Moderator

Re: slow internet speeds even after plan upgrade

Thought the same so I checked, it is actually an 1100. Good catch though.
Moderator

Re: slow internet speeds even after plan upgrade

Hi budkeil

Great, everything looked fine on one tool and I double checked and I am still seeing the original configuration error on another tool. Can you swap the routers and let me know, so I can see if that clears it? If so maybe resetting the Netgear to factory (if that is ok with you) would work. 

Thanks
Amanda