HughesNet Community

Testmy login issue

Showing results for 
Search instead for 
Did you mean: 
Distinguished Professor IV

Testmy login issue doesn't recognize my login.  I use my login credentials and get no errors. I'm taken to the site, but the site does not show me as being logged in.  When I run a test it runs it as though I were not logged in (digression: my speeds are slow.... the max has been around 13 -- no superfast Gen 5 here!).


I have tried a password reset request.  I send it in, get the link, reset my password to my normal password, and the site logs me in and shows me as being logged in.  If I log out and try to log in again, the same issue as before happens (the site does not see me as being logged in).  To get logged in again I have to do a password reset. This is tedious.


Using Windows 10, I've tried this on Chrome, Edge, and Firefox.  Same thing every time.


Anyone else experiencing this?



Welcome to the HughesNet Community!

The HughesNet Community is here for you
to find answers and ask fellow HughesNet
subscribers for help. This is a great
opportunity to discuss and share your
expertise to enhance your HughesNet
experience and that of fellow subscribers.

Visit the About the Community board for
information on how to get started with using
this resource.