cancel
Showing results for 
Search instead for 
Did you mean: 

Hosts File Ignored

Highlighted
New Poster

Hosts File Ignored

I am working on building a website that requires that I use the hosts file on my local machine to redirect to an assigned IP address. It works fine on any network but Hughesnet. It seems that Hughesnet must have its own DNS that is overriding the local hosts file. It there any way around this? Thank you all for you help!
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Associate Professor

Re: Hosts File Ignored

The HT2000w uses a transparent proxy to fetch and load websites, this may interfear with some browsers loading pages based on local host files.

I suggest disabling Web Acceleration, then flush your DNS cache, and see if that helps.

View solution in original post

4 REPLIES 4
Highlighted
Distinguished Professor IV

Re: Hosts File Ignored

@Rally7 

 

Though I don't know if it will work for what you need, you can change the DNS used in the modem by signing into this HughesNet modem page (use admin as the password), then click on Advanced Setup and DNS.  There you can uncheck "Obtain from ISP" and input any DNS you wish.  Keep in mind that this is only IPv4.  There's no way to set the IPv6 DNS in the modem.  

 

Also, though I don't know if it will affect what you're trying to do, HughesNet uses dynamically changing, shared IP addresses rather than a static one for each subscriber.  You can, however, get a static IP with a HughesNet Business account.  Just thought I'd mention in case it does come into play. 


Ryzen 5 3400G | MSI B450M Pro-M2 MAX | 16GB Corsair Vengeance DDR4 3000 | XPG SX8200 Pro 512GB NVMe | Windows 10 Pro
Highlighted
Associate Professor

Re: Hosts File Ignored

The HT2000w uses a transparent proxy to fetch and load websites, this may interfear with some browsers loading pages based on local host files.

I suggest disabling Web Acceleration, then flush your DNS cache, and see if that helps.

View solution in original post

Highlighted
New Poster

Re: Hosts File Ignored

Thank you for taking the time to respond. This did not resolve the issue.
Highlighted
New Poster

Re: Hosts File Ignored

Disabling web acceleration seems to have resolved the issue. Thank you for your help with this issue.