Hughesnet Community

DNS Acceleration[N] ERROR - Slow, Unresponsive Internet Most Times

Showing results for 
Search instead for 
Did you mean: 
Advanced Tutor

DNS Acceleration[N] ERROR - Slow, Unresponsive Internet Most Times


Good Morning Damian,

You have always been very quick to get back to me and help me out so I'm hoping you can help me again with this current connectivity issue I am experiencing.


This past week I've been having noticeable connectivity issues with is causing both very slow, and/or unresponsive internet website loading / streaming behavior. According to the diagnostics (via my System Control Center) the issue appears to be a continuous DNS Acceleration[N] ERROR. (Please see screenshots below)

data.pngdns.pnghughes 111.png

Being a long-time customer (15+ years), I took the liberty of also uploading a screen shot of my current usage as it is 5:03 (pst) am at this very moment which means I am NOT currently throttled. (I still have 23G bonus usage) so I shouldn't be experiencing any connectivity issues. I know this is usually the first thing people 'assume' whenever 'slow, unresponsive' speeds come up as a topic so I figured I would get that out of the way so we can move quickly to resolving whatever the issue actually is.


Back to this DNS Acceleration[N] ERROR, as you can see from the screen shots this is ongoing. I have reset (soft reboot) the modem several times from the system control center, and this morning was the 2nd time doing the hard reboot (unplugging from the brick) in the past 4 days. Nothing I do on my end seems to help. 


I would really appreciate it if you could look into this issue that I'm having so I can get back to enjoying my HughesNet service.


Many thanks..




I can't do anything right now as my entire service went down right at around midnight last night..




Sitting  20 miles up the road again typing this message using my Verizon wireless signal...

It's like dejavu...

This happened last month where I completely lost service although it only happened for a few hours last time.....going on 8 hrs this time


Advanced Tutor


I rebooted the modem before I left hoping for a hail Mary so as not to have to actually leave home but it I didn't do anything

I went to bed early last night with the intentions of getting up at 2:00am to get some work done with my bonus data only to discover the entire service was down.


On my modem, The system light is not on and the transmit light is blinking very very slowly...


Advanced Tutor


 @No service for almost 8 hours now ..



With all the talk about changing this and that DNS setting, for the record I would like it to be known that I have NOT messed with, and/or  changed any settings within the Hughesnet modem /system control center or any other Hughesnet equipment with the exception of power cycling the modem (detaching modem power cord from brick), the last one being done around 7.30 this morning.



Sorry to hear you are still having service issues. I'm asking an engineer here to take a look and see what they can find out. He may need to do some things on his end that will cause the lights to do other funky things. Just leave it as-is now and don't try to powercycle it or anything. I appreciate your patience.

quick edit 4:32pm EST: It should be back online and we're adding tokens, but he is monitoring to see if the DNS errors return.


Advanced Tutor


I read your message while sitting at the top of the hill using my cell phone for service so I drove home and sure enough my service is restored...and green checks all across the board. 


I'll keep monitoring it on my end too...


The tech is coming on Saturday (supposedly...they have rescheduled several times), should I go ahead and keep that appointment? I'm thinking I probably should lol...but I don't know.



Advanced Tutor

My entire Hughesnet service is still down completely ...10+hrs


I cant access the system control center so I have no additional screen shots to provide you ..


The system light is off and has been the entire time..


The transmit light is blinking slowly on and off with period of it being off completely, and the rest of the modem lights are on.

Advanced Tutor


So it is 7.45pm (pst) right now and my internet has been up and running for approx. 6 hours or so.

So far all I have noticed is the brief DNS error pop up this past hour, during a 5 minute shown below.

I'm not sure if this will get worse when the data allowance is exhausted as this is what has happened the past 2 months...


Speaking of data usage, what I did notice is that I've somehow managed to go through almost the entire 5GB's of data tokens that you added just 6 hours ago which I find incredibly difficult to believe. 

So far I have watched a 1.5 hr movie (we have the HughesNet data saver enabled, aka Video Optimizer, not that it looks like it helped us any)


and approx. 20-30 minutes of Roku Live TV via our Roku Device (using my 5.0GHz WiFi frequency). I also browsed a few basic webpages via my desktop computer using the 2.4 GHz frequency. I didn't stream any content or video (Youtube, Facebook, apps, etc. via my desktop computer. I haven't even done any of my work yet since service was restored. Did most of it earlier today while sitting on the hill 20 miles up the road on my phone.

No software updates or anything during these past 6 hours it's quite astonishing that I have gone through 5GB of data in just 5 hours from the internet activity that I have done.



Don't get me wrong, I am truly grateful for the additional 5GB of data that you added even if it was short lived and even more so for the help that I receive from the community members, moderators and engineers. 

I'll continue to keep an eye on things and hope for the best...




Advanced Tutor


Say it isn't so??

So the 5GB token that was added just 6 hours ago is now completely depleted, and at approx. 7:51pm I entered into biggie under normal circumstances...HOWEVER

guess what has reared it's ugly little head immediately when I entered FAP...yup! the DNS error code has once again been triggered.


I'm glad I kept my tech appointment for this coming Saturday...😂



Advanced Tutor


🙄and it only took 3 attempts for this basic HughesNet community webpage to finally load, without timing out, for me to post this...


Hi bare65,


My point of contact here in engineering also left me a note early this morning that he too notice the DNS errors, but that at least now the transmit side of your system that was struggling yesterday is running well (this was the 12.7.2 state code you saw). He is looking more into the DNS issue to try and pinpoint the root cause. Don't worry about posting the screenshots of the x/check log unless you really want to, but engineers here already have access and have a more direct way of polling this info. I can see if there is some way we can help identify the traffic source for some of that data usage as well.


Thank you,



Advanced Tutor



  Screen shot from the past 4 hours, 2am - 6am.  I appreciate that my service is no longer completely out and is transmitting once again, however my main problem is that even during my bonus period, when I do have data allowance, this DNS error prevents me loading even the simplest of webpages....

It really boils down to this DNS error being directly associated with FAP. As soon as I exceed my daytime data usage allowance, the FAP automatically kicks in, which is normal, HOWEVER, in my case, so does this DNS Acceleration error. 

When that happens, it disrupts my service even more so than just the typical slow down you normally see when you are throttled. 


Prior to this all happening, some 2 months ago, whenever I exceeded my data usage, my speeds were a little slower but it really wasn't a big deal. I could still manage /browse the internet, download content, stream TV (Netflix etc) as well as get my daily work done and submit it to my boss...


But throw in this DNS error and all **bleep** breaks loose....


If you could let the engineer know this, I'd appreciate it. 


My tech appointment is still scheduled tomorrow. If they do show up and switch out equipment, perhaps this will resolve the issue at least on my end?? Even though your engineer is working on things, I don't want to cancel this appt. as it was quite the nightmare getting it set up to begin with.

Advanced Tutor

At the moment I have 3 tabs open on my browser, including this one. The other 2 webpages/tabs just won't load. One is my banking website and one is a news website....and I'm still in my Bonus Zone with 26.6G of data allowance.

I have at least 5 hours of 'online' work to get completed for my boss by the end of day and at this rate I'm never going to get through it so I'm packing up my gear and going to drive up to the top of the hill (20 miles away) and use my laptop and hotspot from the Verizon Wireless signal I get up there.

I only get 1 bar with Verizon but I can get more work done with that 1 bar than I can with this...


Advanced Tutor

So incredibly frustrating...

I can't get ANYTHING to load, no webpages or other content on my desktop, certainly nothing on my Roku (streaming apps and so on) is working.

I might as well not be transmitting a signal at all because I can't do anything with it anyways...

I've lost an entire day of work AGAIN.


Below is my last hour of service in 5-minute intervals...


and here are the last 24 hours of service in 1 hour intervals




I texted the technicians/installation company that are 'supposedly' scheduled to come out tomorrow with very detailed driving directions (including GPS coordinates) directly to my front door (the last time they attempted to come out here they got lost), although they have yet to acknowledge that they received those directions.

I will blow a fuse if this repair company tries to re-schedule me and/or uses that all too familiar "we got lost" excuse as a way to get out of driving here tomorrow morning.


Advanced Tutor

Technician just called and is on his way!! 😊 Should get here by 9.30am

The company he works for (CM Wireless) did NOT pass along the driving directions or GPS coordinates that I provided them but thankfully this technician had the good sense to call me BEFORE leaving his location because he had no idea where I was located or how to get here, (my physical address is not on ANY map)

If you factor in that we have no cell phone service out here, he would not of been able to contact me for exact location even if he did happen to get close...


In the event that the tech can't fix this, here is another screen shot from past 12 hours...



Not being able to load / stream/ anything yesterday, as soon as my husband came back home we decided to head to Vegas (90 minutes away) so that my husband could stop by the main office and submit his weekly payroll using their computers/internet as we were still unable to get any webpages to fully load. 

It's one thing if I lose my job over this...but hubby losing his is NOT an option.


I left my desktop computer connected to the WiFi but put it in sleep mode before leaving the house. We got home around 11:30pm (pst) last night.


The blue arrow is the time we were NOT at home. Like I said, my desktop computer was connected to the 2.4GHz WiFi frequency, but was not actively using any data.


This is the exact same thing that has been happening...


The DNS Error code is only initiated when you actually start USING a connected device, and then, it will continue to occur until there is a good 20 minutes of NO activity detected by the modem and/or you disconnect all devices from the modem. From all of my testing, the actual device or frequency being used does not make any difference.


Anyways...hopefully the tech will replace the modem, and/or radio and this will solve the issue...

I have 5 days left in this monthly billing cycle, so my speeds will still be 'throttled' during the day, however, if all goes well and the tech can rid this DNS issue once and for all, I will be able to use the computer and stream apps on my Roku again without any major disruptions, even with the reduced speeds. 

Advanced Tutor

@Amanda @Damian 

I am so incredibly ticked off right now...beyond LIVID!!

The tech came out here, and after I explained the issue in detail, as well as show him the screen shots from these past few days, he replaced the radio saying that there was some sort of screw on the radio that was broken and that he was sure this was causing the issue. 

Really?? a broken screw? okay...I guess I really WAS born yesterday. Perhaps it was the bad weather at the gateway that caused this screw to become loose/broken which in turn set off the DNS error codes??? It could happen right??


In the event that this issue was not resolved I explained to this tech that it would take a good 5-10 minutes for this DNS error code to re-generate on the diagnostic page and asked him if, after he replaced the radio, if he could hang out to make sure the DNS was resolved by replacing this ummm broken screw and radio.


He said that he was already pressed for time but agreed to stay for 5 minutes longer to verify.

He then asked me how I was able to see the diagnostic page as he didn't know how to access it himself.

I actually had to walk him through the process of how to open up the system control center from my desktop computer and locate the diagnostic page.


Anyways, sure enough, after 5 minutes, the diagnostic page started show the DNS error codes was still showing up...


Being that the issue was NOT resolved, he then, very reluctantly, replaced the modem but not before first trying to claim that he didn't have ANY modems with him going on to say that his company doesn't get very many of them. My reply to him was "what HughesNet technician goes on a repair job without bring a spare modem (whether new or old), or two, as well as other equipment?" It was then that he went out to his truck and magically produced another modem.

Ummm yeah...

I asked him if he would, once again, stay for a few minutes after replacing the modem, just to ensure that the issue was resolved this time and he actually got ticked off saying that he had other repairs to get to and didn't have time to further diagnose and/or confirm whether or not the issue was fully resolved.


He then wanted me to SIGN his work order acknowledging that the repair was done AND fully operational.

I refused to sign his work order explaining to him that it was going to take at least another 5-10 minutes to see whether or not the DNS error was fixed.

He got ticked off AGAIN and left....


Sure enough after 5 minutes, I checked the diagnostics and the DNS error code was still showing...

I tried to call him on his phone and he won't answer.

I tried to text the company to let them know what all was going on and they have yet to reply back to me.


These are screen shots taken since he replaced the equipment.






I might add this tech did NOT know how to access the system control center or view the diagnostics page from the system control center. 

I actually had to TEACH him how to do this because he said "we were never shown how to do any of this" ??

Are you kidding me????

When he first tried to connect his phone to my modem via wifi he initially couldn't find which I explained to him that my network was hidden, and that I had changed the SSID network names and passwords on all of my frequencies to prevent any unauthorized users from connecting to my Hughesnet service.

  He said that didn't know what I meant by this and so I had to actually EDUCATE him on how you can 'hide' your network so that no one can see it when they search for active wifi signals. What internet tech doesn't know how to HIDE a network?? What HughesNet repair tech doesn't know how to access a system control center??


This is total B....S




Advanced Tutor

the tech company, not the actual technician, just replied back to my text saying "You should request an upgrade to the new Jupiter 3 system and get unlimited data"


this is their answer to fixing my service???


Advanced Tutor


As you can see from this screen shot, If I sit here and put my device (in this case my desktop computer) into sleep mode for 5-10 minutes, so that no data is being utilized, the DNS error goes away...

but as soon as I access the internet or do anything that involves using reappears and starts disrupting my service making it impossible to get anything to load... doesn't matter what device I am using, my desktop computer, my phone, my husbands phone, my ROKU, my doesn't matter.

It also doesn't matter what wifi frequency I use, 2.5 GHz, 2.5 guest GHz, 5.0GHz, 5.0 guest GHz

This also happens when my modem is connected directly to a devise via ethernet cable.





Advanced Tutor

For the record, I did NOT sign off on this repair, so if my signature magically appears on any workorder related to this repair, it was not done so by me and would therefore constitute forgery.  

Advanced Tutor

It's almost 1:00pm (pst) and I'll be leaving the house for several hours, meaning that none of my devices will be actively using any data. 

The only device that will remain connected to the modem will be my desktop computer (via 2.4GHz WiFi) but it will be placed in sleep mode.

When I return I'll be sure to post a screen shot as I have no doubts that the DNS error code will disappear during this period of inactivity while I'm gone.

I also have no doubts that, when I do return home, the DNS error code will quickly re-appear when I start actively using data again in the form of trying to view webpages or stream video.


this is my last hour screen shot before leaving house...






Advanced Tutor

Well, we got back home at approx. 9:20pm (pst) after being gone for approx. 7 hours.

I woke up my desktop computer and did a little 'surfing' not that I could get any webpages to actually load, but by doing so, it triggered the DNS Acceleration error code to once again start generating.

If you look at this first screen shot (Last 24 Hour's Problem History) you can clearly see the past 7 hours had NO errors showing up under the DNS Acceleration [N] row. My desktop computer was the only device I left connected, but no data was being actively used while we were gone.


This screen shot below (hourly view) if you look, the DNS error once again starts generating at the 25 minute interval, which coincides with the time that I actually started browsing the internet (it took a few minutes for me to wake up my computer and so on) when we got back home 9:25pm (pst)




So...I just don't know what to do now.

I've tested ALL of my devices that connect to the modem, all of which do so via WiFi (my desktop computer, my Motorola phone, my husband's Motorola phone, our Roku stick, and rarely my Onn tablet.

I thought that perhaps my desktop (HP) computer and/or Windows was somehow triggering this DNS error, but this error continues even after my desktop if completely disconnected from the Hughesnet server...

I've tested ALL of my other devices in the same manner to verify that they too are not the cause of this error....


So this DNS error is 100% being generated on the HughesNet side..


When we try to access the internet, or stream apps on our Roku, or do anything else that involves us actually using any amount of data, it somehow triggers this DNS error code and as a result, renders my entire service useless. We can't load webpages, we can't stream anything, this error completely disrupts everything bring our service to a screeching halt.

If we leave our devices connected, but just don't try to use them to access the internet/data allowance in any way or put them to sleep, the DNS error, after 5-10 minutes, will resolve itself and disappear, right up until we attempt to use any devices again.


@Damian @Amanda 

At this point, I don't think it is too much to request that my HughesNet account is credited for an additional month of service being that this is now the 2nd full month I've been experiencing this very same issue with no resolve. I've clearly demonstrated, through numerous screen shots and so on that this is an ongoing, and unresolved issue that I clearly have no control off and should not have to continue paying $71.95 each month that this error continues. 


Hey bare65,  I have read your posts and you are very informative on how things work. I can learn a thing or two. Anyway I have been having issues since 3/13/24 and I called technical support! They told me it was an engineering issue on their end with Hughes net. Then I called back on 3/15/24. I finally got a hold of someone telling me that where my internet signal is coming from iFlagstaff Arizona. The connectivity issues are due to the fact of the weather there. She stated that Hughes net borrows the satellite signals from there. I hope this is only a weather issue.