Hughesnet Community

Error when using Microsoft Edge DNS_PROBE_FINISHED_BAD_SECURE_CONFIG

Showing results for 
Search instead for 
Did you mean: 
New Member

Error when using Microsoft Edge DNS_PROBE_FINISHED_BAD_SECURE_CONFIG

Good morning, I got Hughesnet service on Friday and I can no longer use Microsoft Edge. Every page, link, web address gives me the same error code DNS_PROBE_FINISHED_BAD_SECURE_CONFIG 


I can use Chrome and all other programs since installing the Hughes service, just not EDGE. I work from home and I need to be able to use it! 


I am able to access and use Edge with other Wifi providers so it is not my computer or the browser. I have tried all types of fixes that I have found on Google but nothing has worked.



Distinguished Professor IV

You may have a corrupted DNS. Try this, if you haven't already:

1. Turn off ALL of the devices using the modem (all phones, iPads, computers, etc.)

2. Unplug the modem's power from the wall socket.

3. Wait a minute, then plug the modem back in.

4. Wait about 5 minutes after all the lights on the modem are back on, then turn all your devices on one-by-one.