Hughesnet Community

DNS Acceleration[N] ERROR - Slow, Unresponsive Internet Most Times

Showing results for 
Search instead for 
Did you mean: 
Advanced Tutor

DNS Acceleration[N] ERROR - Slow, Unresponsive Internet Most Times


Good Morning Damian,

You have always been very quick to get back to me and help me out so I'm hoping you can help me again with this current connectivity issue I am experiencing.


This past week I've been having noticeable connectivity issues with is causing both very slow, and/or unresponsive internet website loading / streaming behavior. According to the diagnostics (via my System Control Center) the issue appears to be a continuous DNS Acceleration[N] ERROR. (Please see screenshots below)

data.pngdns.pnghughes 111.png

Being a long-time customer (15+ years), I took the liberty of also uploading a screen shot of my current usage as it is 5:03 (pst) am at this very moment which means I am NOT currently throttled. (I still have 23G bonus usage) so I shouldn't be experiencing any connectivity issues. I know this is usually the first thing people 'assume' whenever 'slow, unresponsive' speeds come up as a topic so I figured I would get that out of the way so we can move quickly to resolving whatever the issue actually is.


Back to this DNS Acceleration[N] ERROR, as you can see from the screen shots this is ongoing. I have reset (soft reboot) the modem several times from the system control center, and this morning was the 2nd time doing the hard reboot (unplugging from the brick) in the past 4 days. Nothing I do on my end seems to help. 


I would really appreciate it if you could look into this issue that I'm having so I can get back to enjoying my HughesNet service.


Many thanks..




Personally, after being a customer and member of this community for over 15 years, it IRKs me when I read that the customer and/or myself are told that our connectivity issues, and/or disruptive are solely due to their being "bad weather at the gateway" 

This is perhaps the #1 'scripted' response you will receive during your entire time as a customer with HughesNet.

I personally believe that HughesNet customer service reps, via phone or chat, are specifically told to tell their customers this, and no doubt very well trained on how to use this one liner "bad weather at the gateway" effectively, in such a way as to shut that customer up at least for a few days, especially NEW customers.


Now don't get me wrong, bad weather, in itself, can, and DOES cause connectivity issues, and often times, even if the weather is nice and sunny on your end, at the gateway end which can be a 1000 miles away, may very well be experiencing very bad weather which is causing the issue, BUT....if this really is the cause, your internet connectivity issues should and almost always clear up within a few hours. 

If you're still experiencing an issue after several DAYS...then this does warrant, in my opinion, some more research.


For me, this is where this community, especially the moderators who are actually HughesNet 'corporate' employees, as well as the huge resources you can find within this community, has been invaluable. 

Personally, it has always been a complete and utter nightmare trying to call HughesNet via the 800#, partly due to the fact I don't have any reliable cell phone reception here, and partly because every time I have called, the reps have been totally clueless. (same exact script every time..."did you unplug the modem? is raining in Seattle **IT sherlock!!) 

Whenever I have a problem, which, again, over the past 15 years, hasn't been very often, I have found it much more effective and less painful to come here and ask for help, versus calling the 800#.

This issue I am currently having is the exception, but only because this DNS issues, as frustrating as it is, is quite unusual.

Usually, the mods will have me back up and running within a few hours, if not days, plus they are always very quick to respond too.....


Also, If you are a NEW customer and not used to your speeds being throttled, you also have to keep an eye on the data your using, because if use up all your data allowance, your speeds are throttled (meaning slowed down) and this too can cause some delay when loading websites, or buffering when trying to stream apps like Netflix and so on.

I've been lucky in that sense because my own 'throttled speeds' each month have not caused much of a disruption at all, and I've always been able to stream my Roku apps, and/or surf the web without any major issues. 


My advice to you @Hannahnasa , if you are still experiencing connectivity issues after a few days, is to initiate your very own post here on the tech support forum, and I have no doubts that one of the moderators will reply back and help you out. You can easily identify a moderator because they will have the word 'mod'  next to their name. see example below. 


ONLY the moderators are actual HughesNet employees, the rest of the people on here are HughesNet customers, some new, some old. Often times though, you will find that it's other customers that will provide you with the info you need to troubleshoot and/or resolve your own modem, wifi issues because more than likely, they too have had the same issue at one time or another.

Distinguished Professor IV

@bare65 , 


Does the DNS issue only happen when you're in FAP?




Yes, and No....

ok, so I'm on a 15GB service plan, and these past 2 months, immediately after I exceed my DAYTIME 08:00-02:00 data allowance of 15GB (Service Plan Data), which usually happens within the first 5 days of my new monthly cycle,  my speeds are throttled and the FAP error will be initiated (you will see the red X's going across the Fair Access Policy row as well as the error code 24.1.1).

This is NORMAL behavior...and exactly what is supposed to happen, however, in addition to that, (and like I said, just these past 2 months) as soon as I enter into FAP, this DNS error is also triggered, and will start displaying red X's across that entire row too, BUT, it's only triggered when I'm actively using my now 'throttled' data...


If my devices are connected to the modem via WiFi or Ethernet but not actually using any data (like sleep mode), and/or I have no devices connected to the WiFi or ethernet, the DNS error will not be triggered and will show a green check mark across that row..but just as soon as I start using data, the DNS error will come right back again and screw up my entire service again.


Here's the kicker though...

You would think that when 2am rolls around and my bonus zone data allowance kicks in, this DNS error would go away....but it doesn't!!


Once I exceed my Daytime data allowance, this DNS error code will continue being triggered for the entire remainder of the month, even during my BONUS ZONE when I ALWAYS still have plenty of data left (2:00am-8:00am 50GB). For example, right at this very moment I still have approx. 26.3GB of BONUS data, so when 2am rolls around I will no longer be in FAP, but...this DNS error code will continue throwing out error codes during that time if I am actively trying to use the computer.

Now, most times I'm sleeping during my bonus zone hours so if I were to take a screen shot when I woke up first thing in the morning it would APPEAR as if everything is good all across the board during the night, but I can tell you with 100% certainty that if I were to get up around 3am, and try to access the internet doing so would, without a doubt, cause the DNS error to be triggered...


When I'm throttled, my speeds are a little slower BUT navigating around the internet, and/or streaming app such as Netflix etc through my Roku have never been an issue.

The addition of this DNS error though, on top of being throttled, is completely disrupting my service rendering it useless approx. 95% of the time and it's been like this going on a full 2 months now.

I can't get anything to load, not even the simplest of webpages, and certainly not streaming services..

I could be completely off-base, but here's a possible theory of what's happening:

The DNS is the web's address book. It converts names like '' to an IP address that it can directly connect to. When a DNS entry for a particular address gets corrupted, the system tries to go somewhere that won't work right, if at all. Each device has an internal, cached copy of the DNS, which sometimes can get corrupted when there's repeated connection failures, as what can happen when there's an interruption in the satellite connection or from a poor wifi connection (e.g., If a device is too far away from the modem). Every time you try to use the internet the DNS gets called, and the system employs acceleration techniques to try to speed up the process, because each ping takes at least a half-second round trip due to the way satellite comms works.

It's very possible that when you hit FAP, your system is getting overloaded from repeated DNS failures - why you're seeing a problem with the system's ability to 'see' the DNS Accelerator (which may be a DNS entry in itself). This could be for any bunch of reasons, but I'm mostly thinking be the use of secure sites (as in https:\\, which is virtually everything) and/or the use of secure Virtual Private Networks (VPNs, which some phones and tablets now employ by default and should be disabled). Without going into too much detail, those kinds of things take a lot longer to return a result on standard satellite, which may be viewed as a 'failure' by one or more of your devices whenever it gets used. If a device thinks there's a failure, it may try again and again, ultimately crushing the DNS entry, which is going to fail by default. When things finally settle down, the DNS Accelerator re-finds itself and the error disappears... until you use it again and the cycle repeats.


Again, just a theory, but I would look at your devices' settings to see if there is something like a VPN being used somewhere.

* Disclaimer: I am a HughesNet customer and not a HughesNet employee. All of my comments are my own and do not necessarily represent HughesNet in any way.
Distinguished Professor IV

@MarkJFine , why would the system throw the same error during the bonus zone, when the user is not in FAP?


It may only need the FAP condition to initially corrupt the DNS, which simply persists into the Bonus period.


Here's an example: Because DNS issues can be so pervasive, it may also be possible that corrupted DNS entries are already propagating throughout every device on the LAN, which is then getting back onto the modem after a reboot, regardless of plan period.


This is why I recommend that if a simple modem reboot doesn't fix a DNS problem, you really should also restart all of the devices on the LAN while the modem is unplugged. That ensures all device DNS caches are also reset without the threat of re-propagating something corrupted back onto the modem, and vice versa.

* Disclaimer: I am a HughesNet customer and not a HughesNet employee. All of my comments are my own and do not necessarily represent HughesNet in any way.
Distinguished Professor IV

@MarkJFine ,


Yes, this makes sense. I hope the OP will clear the DNS [edit: following the recommended procedure] and see if that helps at all. Not sure if they've done that, but it's worth a try.

Finally got this page to load so I could reply...urrg.


So, firstly @MarkJFine 

I wanted to show you this screen shot taken from just about 5 minutes ago to help answer your question from last night. 



It's 7.47 am right now and as you can see, and I'm currently in my Bonus Zone hours, with 26.1GB of data allowance still available.

I'm not in FAP, but...the DNS error is still occurring.


Now, come the 20th when my monthly billing and data is reset and my SERVICE PLAN DATA of 15GB is re-instated, this DNS error code, if it follows the same patter as these past 2 months, will disappear completely right up until the moment I exceed that 15GB of data (which like I said usually only take about 4-5 days, if that)....and then once mt speeds are throttled and I enter FAP, the DNS error will appear for the remainder of the month.



These are the only devices I use, none of which are using a VPN.


My desktop computer, running Windows 10, home edition. (I only use the 2.4 GHz Wifi with my computer because it won't connect to 5 GHz )

My cell phone, Motorola G Power (more times than not my phone is connected to 5 GHz WiFi)

My Roku Express (connects to the 5 GHz WiFi)


So both my desktop computer and my cell phone are located, stationary, approx. 25 ft from the HughesNet modem, almost straight line.

The modem sits directly behind my TV and Roku device.


And just for the record...during my testing last week, I unplugged ALL devices from the Wifi and instead, connected my Smart LG TV (with NO added roku) to the modem via ETHERNET cable for 20 minutes. I verified that there were no additional devices connected to the modem via WiFi and.....

the DNS error code still occurred, in 5 minute intervals, just like it had been with those devices I had connected using WiFi frequency.


So if I am reading your reply @MarkJFine  right,

your suggestion is for me to disconnect all devices from Wifi (which currently is only my desktop computer) 

turn off the modem

Turn on / restart ALL of these 3 devices, while the modem is off, and then turn back on the modem??


I will do that right now...because, it can't hurt right??


I shall return with a screen shot....



Distinguished Professor IV

@bare65 ,

Wow, what a gigantic mess. Did something change in your setup at the time this issue started? Mark mentions VPNs. Was one added at that time? Did something else change?


The most curious thing is that the issue persists into the bonus zone.  


However, it seems the DNS issue doesn't happen at all before you exceed your monthly data allowance, right? That's so peculiar. 

Advanced Tutor


I hope I'm not jumping the gun by saying this but if could see you in person right now, I would give you a massive HUG.

You may have just saved my CAREER!!!

I keep refreshing the diagnostics page every 5 minutes to verify....but, it looks like your suggestion may of worked.


Ok, so this is what I did...

At approx. 8:10 am (pst) I disconnected all of my devices from Wi-Fi, and I also made sure to turn off the 'auto connect' feature so that

none of the devices tried to automatically re-connect when I turned the modem back on and Wi-Fi was detected.


I then unplugged the HT2000W modem, removing the plug from the brick.

I then shut down my desktop computer entirely and restarted it.

I did the same with both my phone and the Roku device.


I waited a full 10 more minutes before restarting the HT2000W modem.

Once it was fully rebooted, I then 'manually' connected my desktop computer  via the 2.4 GHz wifi frequency (timestamp approx. 8.25am pst)

From here I then opened my desktop browser (Microsoft Edge) and opened the following random website pages.


I then clicked on a random video to see if it would stream...


....meanwhile while that was loading

I went into the livingroom, (timestamp approx. 8.38am) and turned on the TV. I then connected the Roku via 5.0 GHZ (guest) Wi-Fi frequency.

I then opened up Netflix and started playing some random show...

While that was going on, I then came back through to my bedroom and connected my phone to the 5.0 (primary) GHz wifi frequency (timestamp approx. 8.38am) 


The very first thing I immediately notice, before even going into the system control panel, is how quickly the webpages up above loaded on my screen, then I noticed that the youtube video was streaming seamlessly on my desktop computer AT THE VERY SAME TIME that Netflix was streaming on the ROKU device, again, all seamlessly together, and forgive my excitement but I am also playing a Youtube video on my cell phone....and it's 8:40 am which means, this is all happening while in FAP.

All 3 of my devices, streaming content and videos, at the very same time, no buffering, no timeouts, no loading issues...


Now it usually takes at least two, 5 minute intervals, for the DNS error to start lighting up again, so I waited until a full hour had past...
meanwhile, I'm STILL streaming away on my TV, my phone is connected, and I have some random Youtube video playing on my desktop as I type this... continue to open up webpages so that my modem sees that my desktop is 'actively' using data...


and here is the screen shots from this past hour....








As you can see, all 3 devices are connected to the WiFi, and both my desktop computer and my Roku TV are currently and actively using data....

...I am currently in FAP (daytime hours) BUT there is no DNS error code is NOT being triggered.


As a result I am back to being able to stream on multiple devices, even while being throttled!!!

Before all of this started, this is how my Hughesnet service was...even after my data was all used up, and my speeds throttled, I was still able to stream via Roku while surf the internet on my desktop and now, thanks to @MarkJFine suggestion it appears that I am now back to being able to do all of that...and then some.


I'm trying not to get overly excited but hearing the Netflix streaming in the background while this random Youtube video continues to stream on my desktop while I am tying this...I mean, WOW!!!!


On Saturday afternoon my boss gave me an ultimatum and made it quite clear I needed to get this connectivity fixed or find other employment. 

We actually drove to Best Buy in Las Vegas this weekend to look at the Starlink equipment, but in all honesty we just can't afford the equipment costs ($599 + tax), not to mention the $120 a month cost to actually use the internet least not right now.


I'm going to continue streaming and browsing here and come back on here around 11:00am (pst) with another screen shot of my diagnostics....

Hopefully, fingers crossed, this DNS issue is completely resolved.

Advanced Tutor



It's now approx. 10:34am, 2.5 hours have gone by, and all is still GOOD!! 😀😁

here is the last hour, in 5-minute increments...



and here is the last 24hr look in 1 hr. increments, with the last 2 hours (columns 17, 16), since I followed your suggestion, showing no errors




I'm going to be leaving here around 2:00pm (pst) to meet up with clients, and have additional clients I'm meeting over the next few days so I'll be gone for several days returning around Wed/Thursday of this week.

I'll be disconnecting all of my devices while I'm gone as I do every time I leave home for an extended period.

hopefully when I come back and re-connect, my service will continue to be good. My monthly billing cycle actually resets on the 20th, so I will be back to fully operation during 8:00am-2:00am daytime plan and will have 15GB of data allowance before going back into FAP.


@MarkJFine @maratsade @Amanda @Damian 


I can't thank you all enough for helping me with this. These past two months has been so incredibly frustrating and has caused me so much grief, especially coming this close to losing my job over this connectivity issues.


In the event I'm jumping the gun and by week end my service goes back to being disrupted throwing out more DNS error codes, I would ask the moderators NOT to go locking this thread just yet so that I can come back at the end of the week with, what I hope, will be my very last, positive update.



Awesome. So glad this worked for you. What I would do if the errors start happening again is to try to note what was happening when it started: What site was being accessed and with what device. May give a clue as to what's killing it later.


At worst, now you know how to get things back to normal again if it does re-occur. The only modification to what you did is to make sure all devices are off at the same time before powering them up again. That ensures the DNS cache is completely flushed on everything you have: TV, cell phone, as well as the Roku. Personally, I have a Roku Ultra in one room and have it unpowered all the time - until I use it. That way it's not using any internet behind my back.


You may also want your spouse to restart their phone before coming home (if they have one) to ensure it's clean and can't re-insert a corrupted DNS entry into the LAN.


* Disclaimer: I am a HughesNet customer and not a HughesNet employee. All of my comments are my own and do not necessarily represent HughesNet in any way.


YES! 5 hours (shown in columns 20 thru 16 ) and still going strong....

I'm back to being able to do everything I need to do with my current 'throttled' speeds, which, in all honesty, for me personally, I find very manageable.




As far as Roku and stuff...

Being that I am on the 15GB plan, and before that, the 10GB plan....I have aways been very careful as to what I leave connected, and the setting for each of my devices. I only connect my devices  when I use them, with my desktop being connected most times as I spend many hours each day working on it from home.

The only time my Roku connects is when I turn on my LG TV...the Roku is connected to my TV via HDMI and connects via when I turn off my TV, the entire Roku completely disconnects from the modem. I actually do not watch TV much myself, my husband is the one who watches it most times, so usually it's only going during the weekends when he is home...and occasionally, during the week if I have free time. 

Being a long-time customer of HughesNet, I'm all too familiar with how quickly data is consumed, and even more so with how different devices can really use a staggering amount of data compared to others.

If I connect my LG TV to the modem directly, whether it be via ethernet, or Wi-Fi, and try to stream app thru that device, firstly...the connection is much slower and it really drains my data much quicker...HOWEVER, some time ago my oldest son told me to try using Roku, and he actually bought us one for Xmas...

I was amazed at the difference...

We no longer use the TV directly to stream apps because of the sheer buffering issues and lag, and instead we only use ROKU via wifi.

My LG TV does not connect to the modem at all....only the Roku. and as a result, my data usage slightly improved, but even better was the performance and loading of the apps, like Netflix and so on significantly improved. 

With my LG TV, especially if I was throttled, I couldn't get certain apps to even load...Amazon Prime being #1 

However, disconnect the TV and stream it thru Roku, even when throttled, its no problem!!


Anyways..I'm headed out the door for a few days but I'll tell you, just in these last 5 hours, I have been able to accomplish so much more work here at home than I have been able to this entire past two months...and for that, I am sincerely grateful to you @MarkJFine ....and I didn't have to drive 20 miles up the road to do so!!!! 

Not only will I keep my job, I'm also going to save a heck of a lot of money on fuel!! 


Hi bare65,


I'm glad to see you've seen improvement based off the additional troubleshooting. generally the idea of turning everything off and then back on is one of our first steps in troubleshooting, but I think we're inclined to assume everyone has already done it and simply forget to ask! We will take this as a learning experience to be more diligent on the basics. Please feel free to choose Mark's response as the solution if you feel this is correct and hopefully it will help other customers who may be facing the same issue. 





Advanced Tutor


WOW! The sarcasm detected in your reply was quite uncalled for and I certainly didn't appreciate it.

and while GENERALLY I would agree with you about turning everything off and on again is basic knowledge, this particular issue that I experienced for 2 FULL MONTHS wasn't merely happening because I wasn't turning on and off all of my devices, because this is something I had done NUMEROUS TIMES over the course of these past two month, as well as turning off /rebooting the modem!!!!


Because of this continued DNS error, my devices needed to be turned off a specific and orderly way to CLEAR the DNS CACHE completely .......

......and this is something you, nor ANY of the HughesNet Technicians / engineers, nor those completely incompetent customer service reps via HughesNet 800# could troubleshoot or HELP me figure up. So obviously this was more than your basic hiccup...


INSTEAD, it took another CUSTOMER, to help me figure this up, this after 2 FULL MONTHS of asking for help for HUGHESNET.

I'm 100% certain that your VERY BASIC troubleshooting guides that HughesNet provides does not make ANY mention of what to do if DNS errors occur and the steps needed to powering down your devices in such a way as to clear that error.......BEFORE unplugging the modem.


This issue went on for 2 full months. I almost lost my JOB and it caused me a great deal of stress trying to get this fixed!!! 

and while Damian did credit my billing for the 1st month, the way I see it, HughesNet still owes me an additional month credit on my bill for this past month. 

How about you save your sarcasm for someone else, and credit my bill....

Thank you!


For the record, over the past 15+ years I have ALWAYS had a great respect for the HughesNet employees at the corporate level working within this community, and I have worked directly with @Amanda on a few occasions during that time, but NEVER, during the entire time I've been a customer have you replied to me is such a sarcastic manner. 

@bare65Think there might be some miscommunication. Think Amanda was just apologizing for not recommending to turn everything off first; as well as recommending you hit the "Solved/Solution" button on the reply with my procedure so it will flag it. That way others with a similar issue can find it in the future.

* Disclaimer: I am a HughesNet customer and not a HughesNet employee. All of my comments are my own and do not necessarily represent HughesNet in any way.

edited to delete my own cranky response.😣

Hi bare65,


MarkJFine is correct. I was simply advocating for the use of our Solution button because it is a good tool to optimize search results within our community. I should have made clear my statement about rebooting was on our side - myself and any other moderator here should be asking people to reset their equipment as the very first step. In our human condition, we've become accustomed to hearing 'I've already done all that", and to avoid upsetting anyone, we shy away from it which can end up with the reverse of our intention.


I believe I've historically been quite straightforward in my responses in the community, so I hope you understand I mean everything sincerely. I do plan on applying credit to your account, however we typically like to ensure there is a real 'all clear' to a problem before having to do multiple transactions. Please accept my apologies for both coming across the way I did, and for not making the reboot recommendation sooner. 


Thank you,


Distinguished Professor IV

Amanda, could the procedure to flush the DNS could be placed in a FAQ? “If this or that is happening, try flushing the DNS first to see if this solves your issue. Follow this procedure…”. Etc.

Advanced Tutor


No apology needed...we are all good. 


I surely can't be the only person out there that experienced this type of disruption due to a DNS error code and even though we still do not know what 'set it off', I think knowing now how to CLEAR it from all devices, as well as the HughesNet modem, would certainly be beneficial to EVERY customer should they too experience this same issue so I have to agree with @maratsade that perhaps a FAQ post specific to the topic of DNS as well as the solution/s on how to resolve any issues/disruptions the DNS cache may be causing would be most beneficial.



p.s for the record I'm not normally this please accept my apology too.


Hi bare65 & maratsade,


Hey, it's Wednesday but that also means closer to Friday! I think we could all use some R&R lately 🙂 I also wanted to let you know I've applied a full month's credit to your account already. 


I think a FAQ is a great idea. We'll work on how to lay the instructions out and publish some as soon as we can. 


Thank you,