cancel
Showing results for 
Search instead for 
Did you mean: 

Slow speed and Latency

Highlighted
Sophomore

Slow speed and Latency

I think I have everything per instructions, my OS is Ubuntu 18.04 LTS. What ever you need I'll get. This is the Download test at 25mb everything with the laptop identifier is no WIFI; https://testmy.net/quickstats/LGriffin The latency seems to be all over the scale but the last bunch I ran were all between 20-45%, but I have seen it as high as 97%. https://testmy.net/latency Thanks Larry
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Associate Professor

Re: Slow speed and Latency

Interesting... Your gateway's provider is Suddenlink (173.219.233.206), which appears to be randomly inserting a 1 second delay... which is not really terrible.

 

What troubles me is when you open up the wait time to 15 seconds, you have a consistent 10 second delay added between your terminal the satellite, which might indicate some kind of handshaking protocol issue. It's always the second number, not the initial one though... and that's weird.

 

Are you on Linux natively or running through a VM?


* Disclaimer: I am a HughesNet customer and not a HughesNet employee. All of my comments are my own and do not necessarily represent HughesNet in any way.

View solution in original post

18 REPLIES 18
Highlighted
Distinguished Professor IV

Re: Slow speed and Latency

@LGriffin 

 

Unfortunately, though testmy's speed results tend to be accurate, their latency readings very often aren't.  They can be wildly off.  I'm not really sure of the reason why.  With that said, the latency link you gave is to the test, but the results shown are actually old tests from various users.  

 

The most accurate latency readings you can get are by running a trace route from your computer to a few different websites, whether using the URL or IP address.


Ryzen 5 3400G | MSI B450M Pro-M2 MAX | 16GB Corsair Vengeance DDR4 3000 | XPG SX8200 Pro 512GB NVMe | Windows 10 Pro
Highlighted
Sophomore

Re: Slow speed and Latency

I wasn't sure about the latency data but I threw it in. I just upgraded to Ubuntu 19.10 and the downloaded started off good but deteriorated as the download progressed. I just ran a speed test and it is not that far off from the best an almost 30% improvement since I posted this msg. Thank you
Highlighted
Distinguished Professor IV

Re: Slow speed and Latency

@LGriffin 

 

That's good that it's improving.  It's possible that your speeds took or are taking a bit of a hit due to so many new devices coming online around Christmas and, more or less, bogging down the system with streaming and updates.  We're all seeing it to at least some extent.  But again, it's good that you're seeing an improvement.  

 

BTW, if you do decide that you want to try a trace route I found these instructions for Linux.  They're actually more similar to the instructions for Windows than I thought they'd be.


Ryzen 5 3400G | MSI B450M Pro-M2 MAX | 16GB Corsair Vengeance DDR4 3000 | XPG SX8200 Pro 512GB NVMe | Windows 10 Pro
Highlighted
Sophomore

Re: Slow speed and Latency

The improvement was short lived though occasionally it does show. After running the test again there was a connection error and then a quick reconnect I want to believe there is more going on than I know. I will run the latency test you provided the link to what ever I can. The is another LTS version 20.04 I'll fix 19.04 first. later
Highlighted
Associate Professor

Re: Slow speed and Latency

Just want to point out that the week or two following Christmas is a real bad time to try to deal with peak time slowness/latency. Tons of people with new stuff that either hasn't been satellite-proofed or needs soft/firmware updates. This, in addition to general load being increased by kids home from school, etc.

 

Sidenote: It's also interesting to watch how same people automatically come to the conclusion that HN is stealing their data, not realizing their brand new IoT toilets are constantly phoning home.


* Disclaimer: I am a HughesNet customer and not a HughesNet employee. All of my comments are my own and do not necessarily represent HughesNet in any way.
Highlighted
Sophomore

Re: Slow speed and Latency

Thanks, Mark, for the re-enforcement of known holiday problem, I'm usually one to get things done in the most expeditious manner and this project maybe longer than that. I have Traceroute installed and preliminary indications are that packets are not getting a return ICMP and dropping connections which I would expect. if high net traffic is adding to an already existing problem. I have the man page print out so I'll see if there is an option to compensate.
Highlighted
Distinguished Professor IV

Re: Slow speed and Latency


@MarkJFine wrote: 

Sidenote: It's also interesting to watch how same people automatically come to the conclusion that HN is stealing their data, not realizing their brand new IoT toilets are constantly phoning home.


They're just flushing their data away!!!  Smiley Tongue Smiley Tongue Smiley Tongue 

 

Sorry to take this thread a little off topic, but I just couldn't resist.  When I read what you wrote that thought immediately came to mind.


Ryzen 5 3400G | MSI B450M Pro-M2 MAX | 16GB Corsair Vengeance DDR4 3000 | XPG SX8200 Pro 512GB NVMe | Windows 10 Pro
Highlighted
Associate Professor

Re: Slow speed and Latency


@GabeU wrote:

They're just flushing their data away!!!  Smiley Tongue Smiley Tongue Smiley Tongue 

I was waiting for someone with a follow-up.

🥁 <cymbal crash>


* Disclaimer: I am a HughesNet customer and not a HughesNet employee. All of my comments are my own and do not necessarily represent HughesNet in any way.
Highlighted
Sophomore

Re: Slow speed and Latency

Project went better than expected I started with traceroute google.com no options. Then I ran traceroute with option w10 a 10 second wait for ICMP a we bit of change. Next with w15 and t 16 big difference. I probably shouldn't have added the t 16 option so I reran the previous with w10 not the same results. I thought there might a change in type of service or something because 8 consistently falls out. I read the link on Latency that was posted so I added a few lines from a ping of google.com. Here is the link; https://drive.google.com/file/d/1kSK6840PO5XE6Wf0CT5Gx6ljeD_KHKFt/view?usp=sharing The man page for traceroute is here; https://drive.google.com/file/d/1J3aXZtdHy6jHNB4jM7dOWD3f6h7vIVO0/view?usp=sharing I don't know that I can add more but there certainly seems to be enough delay present to affect speed. Any for further suggestion for additional work with traceroute gladly accepted. Happy New Year!