HughesNet Community

Unable to load Amazon, Problem Upstream From Modem

cancel
Showing results for 
Search instead for 
Did you mean: 
whysalives
Sophomore

Unable to load Amazon, Problem Upstream From Modem

I have bypassed my router with a direct cable connection to the modem, turned off web acceleration, reset the MBX, and have attempted rebooting the modem.  The problem is across computers, users, and browsers.  I have attempted shuting off windows firewall and antivirus.  All to no avail.  Yesterday, while in the middle of browsing Amazon, images suddenly stopped loading.  Today, in addition to few or no images, Amazon tries to load at a snails pace but the CSS never fully loads.  This problem ONLY occures with Amazon and only started occuring yesterday.  I have attempted clearing cookies and cache and uninstalled all extensions and tried incongnito mode and tried both chrome and explorer, but as I said, this problem is either at the modem or upstream from it.  It doesn't matter if I'm using my laptop on wi-fi, my tower with network cable, any windows user, any browser, the problem persists.  It only affects Amazon.com.

 

amazon.jpg

1 ACCEPTED SOLUTION

Good morning everyone,

 

Just got word that Amazon should be working properly now. If you made any workaround changes, please revert back to your original settings and give it a test run.

 

Thank you,

Amanda

View solution in original post

60 REPLIES 60
Amanda
Moderator

Hi whysalives,

 

What an odd issue! I would like to bring this up with our network engineers to see what they can uncover. Just curious, do you have any success loading Amazon on a mobile app? Or have you tried loading Amazon.com on a different provider?

 

Thank you,

Amanda

Same problem here! Even the mobile app on my android does the same thing as does the chrome and Samsung internets. My Toshiba laptop is having the same issue. Getting very frustrated!

It does not load in safari on my ipad, but it does load in safari on my ipod touch.  Both are using the wireless router in this case.

 

I have physically unplugged the modem, router, and the coaxil to the dish for over a minute with no change in results.

 

I would like to reiterate that bypassing the router also does not change the results.

That's curious.

Are you able to open a terminal and do a traceroute to amazon.com?

If so, could you do so and post a screenshot here?

 

Edit: Was also thinking what if you tried "rebooting" the devices you are having the problem on. Could be possible they're using a local DNS as well.


* Disclaimer: I am a HughesNet customer and not a HughesNet employee. All of my comments are my own and do not necessarily represent HughesNet in any way.

**CORRECTION**

 

It does not load properly on my ipod touch.  It appeared to at first, but indeed it is having difficulty rendering pages.

 

Rebooting my laptop and tower was the first thing I tried in addition to rebooting the modem.

 

Here is a trace with the router, wirelessly from my laptop:

 

trace_with_router.jpg

 

Here is a trace with a direct cable connection from the modem to my laptop:

 

trace_no_router.jpg

Okay, I decided to throw everything at it at once.  I unplugged the modem, router, and dish.  I shutdown and restarted the laptop.  I connected the modem directly to the laptop and turned everything back on.  I reset the MBX, turned off web acceleration, disabled windows anti virus and windows firewall for both public and private networks.  I then cleared my cache and cookies and loaded amazon.com with control-shift for full refresh.

 

Viola!  It worked.

 

I've turned the router back on, went back to wireless, turned on my anti virus and firewall, and turned web accelaration back on.  Amazon.com is loading properly!

 

No idea what happened there.

For completeness, here is my current trace from my wireless laptop, now that everything is working:

 

trace_with_router_fixed.jpg

 

Thank you for your help.

C0RR0SIVE
Associate Professor


@whysalives wrote:

 

Here is a trace with a direct cable connection from the modem to my laptop:

 

trace_no_router.jpg


For some reason that trace doesn't strike me as normal... Not used to seeing a lot of in-addr.arpa entries like that.

All that aside, it could have been anything really... Amazon, DNS, broken routing somewhere... No telling.

Yeah, almost looks like either qwest or most likely amazon.

Did notice that the IP resolved from 54.239.25.208 before complete reboot to 54.239.17.6 after, so could have also been the local DNS getting stuck on something weird.

 

Edit: Either way... looks like a team win.


* Disclaimer: I am a HughesNet customer and not a HughesNet employee. All of my comments are my own and do not necessarily represent HughesNet in any way.
GabeU
Distinguished Professor IV

For some reason I tend to have a lot of issues with Amazon.  Not much else, but Amazon gives me non connection issues on a semi regular basis.  What I usually do to rectify it is flush the DNS.  It happens most often when I am using Google's DNS, not when I'm using Hughesnet's.  The DNS flush normally does the trick, though the issue does tend to crop back up after a time.  

 

I don't know what it is about Amazon that causes this, but I don't see it very often with other web sites.  

 


Ryzen 5 3400G | MSI B450M Pro-M2 MAX | 16GB Corsair Vengeance DDR4 3000 | XPG SX8200 Pro 512GB NVMe | Windows 10 Pro
macsociety
Advanced Tutor

Back when I owned Gen 4 (on Gen 5 now), I had similar issue but with Paypal.  For the life of me emptying cache and all that, multiple systems, etc... I could not get paypal to work.  Unplug the modem, wait a few minutes, reconnected, and walla!   it now worked.

 

Have you tried unplugging your modem and leaving unpowered for a few and trying again?  Was not sure if rebooting the modem meant a soft reset from the admin at 192.168.0.1 or a unplug.

 

TJ

C0RR0SIVE
Associate Professor

Could be a corrupted DNS cache causing this.

You may want to consider disconnecting power to the modem, and your third party router, then change the DNS provider to Googles DNS.  Once you have done that, you may want to flush your DNS records on your computer.

 

 If that doesn't work, you may want to change your DNS server on your computer back to Automatic.

Was just about to also suggest it might be a DNS problem.

I've also had a problem where Amazon wouldn't load in the past. Rebooting the modem and any other external routers fixed it right up.


* Disclaimer: I am a HughesNet customer and not a HughesNet employee. All of my comments are my own and do not necessarily represent HughesNet in any way.

Thanks for all the replies! Can those with the issue give rebooting the modem/router a try? If that doesn't work, let me know. I am still waiting on an engineering reply.

 

~Amanda

Having the  same issue here; rebooted the modem, same issue on various devices and browsers, nd only affecting Amazon.com

Gil
Freshman

I had the same problem and did everything you stated to no avail.  However, the only thing I didn't do was to unplug the modem.  So I shut down my laptop, unplugged the modem for several minutes, plugged modem back in, restarted and viola!  Amazon dilemma resolved!  

 

Update - After several days of trouble-free shopping on Amazon, the problem reoccured.  I'm not technically savvy, but following the OP's advice, rebooting the modem once again (in my case) resolved the issue, at least temporarily.  I've also experienced similar scenarios on other secure web sites (i.e. banking), but rebooting the modem always gets me back in.  It appears to be problematic on HughesNet's end.

HS
New Poster

I've unplugged and rebooted the modem multiple times. I've restarted my PC multiple times. Same with the Mac. Still can't use Amazon. Any other suggestions besides sign up with a different ISP or switch from Amazon to brick and mortar?

My Amazon screen looks the same as whysalives's original screen shot.

Still.Amazon screenshot 2017-10-30_6-35-47.jpg

 

Looks like it's not getting the css. That's usually a DNS issue.

DNS's propagate, so if you're rebooting the modem and router while the computer is up and it's DNS is corrupted, you're not doing anything to clear the computer's local DNS.

Either bring everything down simultaneously or flush the computer's DNS cache.


* Disclaimer: I am a HughesNet customer and not a HughesNet employee. All of my comments are my own and do not necessarily represent HughesNet in any way.